Getting started

You can use the Microsoft Expression Web Software Development Kit (SDK) to extend the capabilities of Expression Web. In addition to the managed code Application Programming Interface (API), Expression Web introduces a JavaScript API and a JavaScript bridge to the managed code API.

Programming reference topics are provided for both managed code and JavaScript. Additional content may be available at the following locations:

  • Expression Gallery

  • Expression Library

Getting started with the SDK

Start learning about the Expression Web SDK by reading the following topics:

  • Developing add-ins using JavaScript

  • JavaScript programming reference

  • Managed code programming reference

Helpful things to know when you read topics

  • In the Programming reference section, you can collapse all the sections in a topic to view a list of headings by clicking the Collapse All link at the top of the topic.

  • To show or hide different languages for code samples in a topic, select or clear the check boxes in the Language Filter drop-down list at the top of the topic.

  • To print a topic, click inside the topic window, and then press CTRL+P.

Copyright © 2010 by Microsoft Corporation. All rights reserved.


Developing add-ins using JavaScript

Developing extensions in JavaScript and HTML is more familiar to web developers than developing extensions in managed or native code, and is thus easier.

One of the benefits of developing Microsoft Expression Web add-ins in JavaScript is that you can use Expression Web as your development environment.

Using Expression Web for add-in development

In addition to the JavaScript files that provide the logic for an add-in, you can construct panels and dialog boxes using HTML and control their appearance with cascading style sheets.

Although Expression Web does not have a built-in JavaScript debugger, you can use alert() statements to display the value of variables, code execution locations, and so on. Additionally, including developer="yes" in the add-in manifest creates a debug console that can be written to, and that has some rudimentary JavaScript error reporting.

For more information about configuring these options in the manifest, see Debugging options in the manifest.

Configuring the add-in development environment

Treat the add-in project as a single site in Expression Web to simplify the process of managing the assets that your add-in uses.

A simple panel add-in site structure might look something like the following:

w4 SDK add-in site

See Also

Concepts

JavaScript programming reference
The add-in manifest
Packaging an add-in for distribution


The add-in manifest

Each add-in requires a manifest file, which is always named "addin.xml." The manifest describes specific aspects of the add-in that are used by Microsoft Expression Web to join the add-in to the program, to create its user interface, and to subscribe to events. Every add-in requires a properly formatted manifest file that must exist in the top level of the folder that contains the add-in and its assets.

A manifest file is an XML file that can describe multiple panels, commands, dialogs boxes, and event-driven behaviors, and also multiple entry points for the same functionality, such as menu commands and toolbar buttons.

important note Note:

All tag and attribute text in a manifest file must be lowercase. Errors in a manifest file will generally prevent Expression Web from loading the add-in.

The following elements and their attributes comprise a manifest.

addin

[required]

<addin src=" filename" legacy="yes" developer="yes" navigationallowed="yes">

The addin element is the top-level tag for the manifest file. Only a single addin tag is permitted in each addin.xml file. A single entry for each add-in will appear in the Manage Add-Ins dialog box. If you have described multiple extensions (for example, dialog box add-in, panel add-in) in a single addin.xml file, they will all be enabled or disabled through that single entry in the Manage Add-Ins dialog box.

Attributes

developer="yes" [optional]

The developer="yes" attribute adds several features that make add-in development easier. First, the shortcut menu for panels and dialog boxes is typically suppressed during program execution. The developer="yes" attribute re-enables the shortcut menu so that you can refresh the panel or dialog-box interface without restarting the program. Additionally, when developer="yes" is specified, a debug window with the name of the add-in folder is created under the Panels menu. Using xweb.developer.write() and xweb.developer.writeline(), you can send output to the debug window.

For more information about debugging, see Debugging options in the manifest.

legacy="yes" [optional]

The legacy="yes" attribute provides access to Expression Web COM functions (and associated object model) via JavaScript. The COM functionality provides access to a larger scope of functionality than the JavaScript object model at the cost of additional complexity.

important note Note:

Access to the legacy COM functions is not supported.

navigationallowed="yes" [optional]

The navigationallowed="yes" attribute allows the user to use links within the page to navigate to different pages.

As a default security setting, panel and dialog-box interfaces are not permitted to navigate to other pages. This applies to the main pages, and also to any iframe pages that are part of the interface. This makes it impossible to create interfaces that behave like wizards. The navigationallowed="yes" attribute removes this restriction.

Note Note:

The same capability is provided by developer="yes", but developer="yes" also creates a debug console, which generally should not be displayed to the end user.

src=" filename " [optional]

The src attribute is the name of the source file where functions referenced in the manifest can be found. The path of the file is relative to the top level of the add-in folder. You can specify multiple files by separating each file name with a comma (,).

name

[required]

The name element determines the display name of the add-in as it will appear in the Manage Add-ins dialog box.

This element has no attributes.

author

[optional]

The author element specifies the author of the add-in as it will appear in the Manage Add-ins dialog box.

This element has no attributes.

description

[optional]

The description element determines the description of the add-in as it will appear in the Manage Add-ins dialog box.

This element has no attributes.

guid

[optional]

The guid element specifies a unique identifier that could be used to differentiate add-ins with the same name and might be used in the future to help a user upgrade to a newer version of an add-in. If included, it must be in the form: hhhhhhhh-hhhh-hhhh-hhhh-hhhhhhhhhhhh, where h is any single hexadecimal digit. The guidgen.exe that comes with Microsoft Visual Studio can be used to create GUIDs, as can the following site:

http://www.guidgen.com

Note Note:

Expression Web 4 does not check the value of the guid element. This element is a placeholder for future versions.

This element has no attributes.

homepage

[optional]

The homepage element specifies the home page where the user can find information about the add-in. No special format is enforced for this field.

This element has no attributes.

minversion

[optional]

The minversion element specifies the minimum version of Expression Web required to run the add-in. If included, the minversion element must follow the format w.x.y.z, where w is the major version number and is required, and x, y, and z are optional minor version numbers.

Note Note:

Expression Web 4 does not check the value of the minversion element. This element is a placeholder for future versions.

This element has no attributes.

version

[optional]

The version element specifies the version of the add-in as it will appear in the Manage Add-ins dialog box. If included, the version element must follow the format w.x.y.z, where w is the major version number and is required, and x, y, and z are optional minor version numbers.

This element has no attributes.

command

[required only for commands; do not include for panels]

The command element specifies the command that will instantiate the add-in.

Attributes

id=" unique ID " [required]

The id attribute is a unique string used to identify this command tag. It is used internally by Expression Web.

onclick=" expression " [default]

The onclick attribute specifies the JavaScript expression that will be executed when the add-in is invoked. The onclick expression is typically used for command add-ins that execute without a user interface when a menu command is selected. To call a JavaScript function, use the function name with the parentheses.

filetype=" list of comma-separated file types " [optional]

The filetype attribute is used to specify what kinds of files the command can work with. If the active document is associated with the filetype list, the menu item, the toolbar button, or both will be enabled. Otherwise, they will be disabled. The following is a list of valid file types:

  • HTML An HTML file with the file name extension .htm or .html.

  • PHP A PHP file with the file name extension .php, .php3, or .php4.

  • ASP An ASP or ASPX file with the file name extension. asp, .aspx, .ascx, or .asmx.

  • CSS A cascading styles sheet (CSS) file with the file name extension .css.

  • JS A JavaScript file with the file name extension .js.

  • HTML-DOM An HTML, PHP, ASP, or ASPX file that contains an HTML DOM.

  • TXT A plain text file with the file name extension .txt.

  • XML An XML file with the file name extension .xml.

menuitem

[optional, child of command]

The menuitem element specifies the menu item created to execute the add-in, or to make the panel visible if it is a panel add-in.

Attributes

label=" label " [required]

The label attribute specifies the text appearing on the parent menu used to execute the add-in.

parent=" menu name " [required]

The parent attribute specifies the main application menu to which this menu item is attached, and menu name is the internal name of the menu, in the format "MENU_Name" (for example, MENU_File, MENU_Edit, MENU_Insert).

before=" menu item " [optional]

The before attribute specifies the menu item before which the add-in menu item is inserted, and menu item is the internal name of the menu, in the format "MENU_Name" (for example, MENU_File_Save, MENU_Edit_Paste).

imagesrc=" image filename " [optional]

The imagesrc attribute specifies the name of the icon file used to represent this command on the referenced menu. Icons should be 16x16 pixels in either PNG or JPG format.

tooltip=" text " [optional]

The tooltip attribute specifies the tooltip text that is displayed when the user moves the pointer over the menu item.

toolbaritem

[optional, child of command]

The toolbaritem element specifies the menu item created to execute the add-in, or to make the panel visible if it is a panel add-in.

Attributes

label=" label " [required]

The label attribute specifies the text that is displayed in the toolbar for this item. Text, an icon, or both may appear on the toolbar.

parent=" menu name " [required]

The parent attribute specifies the toolbar to which this item is attached, and toolbar name is the internal name of the toolbar, in the format "TOOLBAR_Name" (for example, TOOLBAR _File).

before=" menu item " [optional]

The before attribute specifies the toolbar item before which the add-in toolbar item is inserted, and toolbar item is the internal name of the menu, in the format "TOOLBAR_Name" (for example, TOOLBAR_File_Save).

imagesrc=" image filename " [optional]

The imagesrc attribute specifies the name of the icon file used to represent this command on the referenced menu. Icons should be 16x16 pixels in either PNG or JPG format.

tooltip=" text " [optional]

The tooltip attribute specifies the tooltip text that is displayed when the user moves the pointer over the menu item.

panel

[required for panels]

The panel element defines a modeless panel add-in.

Attributes

id=" unique ID " [required]

The id attribute specifies a unique string used to identify this panel. It is used internally by Expression Web.

title=" title text " [required]

The title attribute specifies the title text of the panel as displayed in its title bar.

activate=" expression " [optional]

The activate attribute specifies the function or expression that will be executed whenever the type of active document matches the file list specified in the filetype attribute. Use this function to make sure that the controls on your panel are active.

deactivate=" expression " [optional]

The deactivate attribute specifies the function or expression that will be executed whenever the type of active document does not match the file list specified in the filetype attribute. Use this function to hide or disable the controls on your panel.

filetype=" list of comma-separated file types " [optional]

The filetype attribute is used in conjunction with the activate and deactivate attributes to control how your panel behaves for specific file types. The following is a list of valid file types:

  • HTML An HTML file with the file name extension .htm or .html.

  • PHP A PHP file with the file name extension .php, .php3, or .php4.

  • ASP An ASP or ASPX file with the file name extension .asp, .aspx, .ascx, or .asmx.

  • CSS A cascading styles sheet (CSS) file with the file name extension .css.

  • JS A JavaScript file with the file name extension .js.

  • HTML-DOM An HTML, PHP, ASP, or ASPX file that contains an HTML DOM.

  • TXT A plain text file with the file name extension .txt.

  • XML An XML file with the file name extension .xml.

ondocumentchanged=" expression " [optional]

The ondocumentchanged attribute specifies the function that will be executed whenever the active document in Expression Web (the visible Design, Code, or Split view) is changed either by the user or by programmatic interaction.

Note Note:

User changes to the contents of the active document are not treated as DocumentChanged events, the scope of which is limited to replacing the current active document with another active document.

The ondocumentchanged attribute is typically set to supportedDocType( doc types, function ).

ondocumentsaved=" expression " [optional]

The ondocumentsaved attribute specifies the function that will be executed whenever a document is saved to disk, regardless of content changes or whether the page is saved by clicking an icon, clicking a menu item, or using a keyboard shortcut.

onelementchanged=" expression " [optional]

The onelementchanged attribute specifies the function that will be executed whenever an element in the active document in Expression Web (the visible Design, Code, or Split view) is selected or changed by either user or programmatic interaction.

Note Note:

User changes to an element are not treated as ElementChanged events, the scope of which is limited to changing the current active element to another active element.

Sample manifest file

Xml CopyCode image Copy Code
<?xml version="1.0" encoding="utf-8" ?>

<addin src="addin.js;addin2.js">

     <name>JS Test</name>
     <description>A description</description>
     <version>1.0</version>

     <command id="mySimplestAction">
          <menuitem
               parent="MENU_File"
               before="MENU_File_Save"
               label="Auto enable/disable"/>
     </command>

     <command id="mySimplestAction2">
          <toolbaritem
               parent="TOOLBAR_File"
               before="TOOLBAR_File_Save"
               imagesrc="addin_img-3.jpg"/>
     </command>

     <command
          id="myComplicatedAction"
          onclick="function()">

          <toolbaritem
               parent="TOOLBAR_File"
               before="TOOLBAR_File_Save"
               label="Auto enable/disable"/>

          <menuitem
               parent="MENU_File"
               before="MENU_File_Save"
               label="Auto enable/disable"
               imagesrc="addin_img-2.png"
               tooltip="First Menu item"/>

     <command
          id="ShowDialogCommand"
          onclick="showHTMLDialog('thisDialog.html', null, 'dialogwidth:300; dialogHeight:200')">
          <menuitem
               parent="MENU_File"
               before="MENU_File_Save"
               label="Extension File Save"
               tooltip="Displays a dialog"/>
     </command>

     <panel
          panelid="Listener"
          title="Listener"
          src="pluginListener.html"
          ondocumentchanged="documentChanged()"
          onelementchanged="elementChanged()"/>

     <command id="MENU_Panels_Addins">
          <menuitem
               parent="MENU_Panels"
               label="Addins ..."/>
     </command>
     <command id="MENU_Panels_Addins_FirstCommand">
          <menuitem
               parent="MENU_Panels_Addins"
               label="First menu item"/>
     </command>
</addin>


Debugging options in the manifest

Microsoft Expression Web includes new options to help streamline the extension development process.

Disabling Safe Mode

In Expression Web, Safe Mode is enabled by default to help protect your work in case the application stops responding. Typically, if something causes Expression Web to close unexpectedly, the next time you run Expression Web, it automatically restarts in Safe Mode, which disables all add-ins. In this scenario, Expression Web has to be restarted to re-enable add-ins. This can be time-consuming when a developer is working on a new add-in.

To disable Safe Mode in Expression Web, in the Expression Web installation folder, create an empty text file and name it safesuppress.txt.

Refreshing panels

Typically, it is not possible to refresh an HTML dialog box or panel while developing an extension. Expression Web provides a switch to allow refresh functionality in the associated add-in.

To enable refresh for an add-in, include the following element in the manifest for the add-in.

CopyCode image Copy Code
<developer="yes" />

Debugging tools

Expression Web provides three ways to retrieve useful debugging information while developing add-ins.

Using alert statements

To display the values of variables or a location within the code, use JavaScript alert() statements.

The debug console

Expression Web includes a simple debug console. Specifying developer="yes" in the manifest for the add-in creates a debug console (with the name of the enclosing folder) that can be written to, and that has some rudimentary JavaScript error reporting.

Note Note:

The debug console is associated with the add-in that invokes it.

Extensions can write to the debug console from JavaScript using xweb.developer.write(string) and xweb.developer.writeLine(string).

xweb.developer.write( string )

Sends string to the debug console window.

xweb.developer.writeLine( string )

Sends string to a new line in the debug console window.

See Also

Concepts

The add-in manifest


Packaging an add-in for distribution

A Microsoft Expression Web extension package is just a renamed .zip file that contains all the files used by the extension.

Structuring the package

All of the components of an add-in must be included within a single folder before you can create a redistributable package. Although assets for the add-in may be organized in subfolders, those subfolders must also reside within the add-in folder.

important note Note:

The manifest file, addin.xml, must also be included in the add-in folder.

Add-in folder structure

The name of the add-in (as displayed in the Expression Web Manage Add-ins dialog box) is determined by the <name> property in the addin.xml manifest file, not by the name of the folder.

For more information, see The add-in manifest.

To create an extension package

  1. Create a .zip file of the folder that contains your add-in. For example, if your add-in folder is named myAddin, in Windows Explorer, right-click on the myAddin folder, click Send to, and then click Compressed (zipped) folder. Windows creates the .zip file, naming it "myAddin.zip."

  2. Rename the file to change the file name extension to .xadd. The example file should now be named "myAddin.xadd."

To install an extension package

  1. In Expression Web, click Tools, and then click Add-Ins. The Manage Add-ins dialog box is displayed.

  2. Click Install, browse to the location of the add-in you want to install, and then click Open. The extension is unpacked and added to the list of add-ins.

    Note Note:

    When you install an add-in, it is immediately available in Expression Web.

Expression Web add-ins must be installed using the Expression Web Manage Add-ins dialog box.

See Also

Concepts

Developing add-ins using JavaScript


JavaScript programming reference

Objects

Object model hierarchies

xweb

xweb.application

xweb.developer

xweb.document

xweb.file

xweb.document.htmlElement

xweb.document.selection

See Also

Concepts

Developing add-ins using JavaScript


Object model hierarchies

The Microsoft Expression Web JavaScript Object Model shows the capabilities exposed by the Expression Web JavaScript extensibility programming interface.

The Expression Web JavaScript Object Model

Expression Web object model hierarchy

See Also

Concepts

xweb
xweb Properties


xweb

This object provides the primary bridge from JavaScript to access the extensibility object model.

Syntax

JScript CopyCode image Copy Code
xweb

Parameters

None.

Returns

Nothing.

See Also

Concepts

xweb Members


xweb Members

The following tables list the members exposed by the xweb type.

Public Properties

Name | Description
xweb.application | The namespace used for functions in the manifest.
xweb.developer | The namespace used for functions referenced and used in the manifest.
xweb.document | The Document Object Model (DOM) of the currently open page.
xweb.file | The namespace used for basic file manipulation.

See Also

Concepts

xweb Properties
xweb


xweb Properties

Public Properties

Name | Description
xweb.application | The namespace used for functions in the manifest.
xweb.developer | The namespace used for functions referenced and used in the manifest.
xweb.document | The Document Object Model (DOM) of the currently open page.
xweb.file | The namespace used for basic file manipulation.

See Also

Concepts

xweb Members
xweb


xweb.application

The xweb.application object contains several methods to initialize and change documents, as well as application utility methods.

Syntax

JScript CopyCode image Copy Code
xweb.application

Parameters

None.

Returns

Nothing.

See Also

Concepts

xweb.application Members
xweb


xweb.application Members

The following tables list the members exposed by the xweb.application type.

Public Properties

Name | Description
xweb.application.settings | Stores information that persists between sessions of Microsoft Expression Web, such as user preferences or other options defined in the add-in.
xweb.application.version | The version number of Expression Web. Read-only.

Public Methods

Name Description

xweb.application.chooseFile

Creates an Open File dialog box.

xweb.application.endDialog

Closes a modal dialog box.

xweb.application.handleEvent

Designates Expression Web as the handler for the specified event, rather than an open browser window.

Note Note:

The handleEvent method currently supports only keydown events.

xweb.application.newDocument

Creates a new web page document and gives the new document focus.

xweb.application.openDocument

Opens a document for editing in a new tab in Microsoft Expression Web and gives the specified document focus, just as if the user had opened the file from the File menu.

xweb.application.refreshFileListing

Refreshes the file list in the Folder List panel.

xweb.application.setActiveDocument

Switches the active tab in Microsoft Expression Web to the specified document.

xweb.application.setPanelVisibility

Changes the visibility state of the specified floating panel.

xweb.application.showModalDialog

Displays a modal dialog box.

See Also

Concepts

xweb.application
xweb


xweb.application Methods

Public Methods

Name Description

xweb.application.chooseFile

Creates an Open File dialog box.

xweb.application.endDialog

Closes a modal dialog box.

xweb.application.handleEvent

Designates Microsoft Expression Web as the handler for the specified event, rather than an open browser window.

Note Note:

The handleEvent method currently supports only keydown events.

xweb.application.newDocument

Creates a new web page document and gives the new document focus.

xweb.application.openDocument

Opens a document for editing in a new tab in Microsoft Expression Web and gives the specified document focus, just as if the user had opened the file from the File menu.

xweb.application.refreshFileListing

Refreshes the file list in the Folder List panel.

xweb.application.setActiveDocument

Switches the active tab in Microsoft Expression Web to the specified document.

xweb.application.setPanelVisibility

Changes the visibility state of the specified floating panel.

xweb.application.showModalDialog

Displays a modal dialog box.

See Also

Concepts

xweb.application
xweb


xweb.application.chooseFile

This function opens an Open File dialog box.

Note Note:

If the user chooses files that are outside the site folder, and if pages within the site include references to those files, the user will automatically be prompted to copy the files into the site when the page is saved.

Syntax

CopyCode image Copy Code
function xweb.application.chooseFile(
filterDescription : String,
filterExtensions : String
) : String

Parameters

filterDescription The title to display on the filter for the Open File dialog box.

filterExtensions The file filter to apply to the contents of the directory being interrogated. For example, *.htm would display only files with the .htm extension. You can apply multiple filters separated by a comma (,).

Returns

This function returns the path of the selected file, or null if unsuccessful or cancelled.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application.endDialog

This function closes an open modal dialog box and is typically attached to the onclick function of the Close button in the modal dialog box.

Syntax

CopyCode image Copy Code
function xweb.application.endDialog(
result : boolean
)

Parameters

None.

Returns

true The specified dialog box was closed.

false The specified dialog box was not closed.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application.handleEvent

This function directs Microsoft Expression Web to process the specified event, rather than to allow a default keyboard shortcut in the browser to process the event.

Syntax

CopyCode image Copy Code
function xweb.application.handleEvent(
eventObject : IHTMLEventObj
) : boolean

Parameters

eventObject A standard JavaScript event from a keydown event handler.

Returns

true The event was processed by Expression Web.

false The event was not processed by Expression Web.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application.newDocument

This function creates a new web page document and gives the new document focus, just as if the user had created a new document from the File menu.

Syntax

CopyCode image Copy Code
function xweb.application.newDocument(
type : String
) : document

Parameters

type Specifies the <doctype> from the list available from the Authoring tab of the Page Editor Options dialog box.

If no type is specified, the <doctype> specified in the Authoring tab of the Page Editor Options dialog box is used.

Returns

This function returns the xweb.document object for the new document, or null if a new document was not successfully created.

See Also

Concepts

xweb.document
xweb.application
xweb.application Members
xweb


xweb.application.openDocument

This function opens a document for editing in a new tab in Microsoft Expression Web and gives the specified document focus, just as if the user had opened the file from the File menu.

important note Note:

This function will open only web page file types, such as file.html or file.aspx.

Syntax

CopyCode image Copy Code
function xweb.application.openDocument(
fileLocation : String
) : Object

Parameters

fileLocation The location of the file, which must be within the site.

Returns

This function returns the xweb.document object for the page opened, or null if it is unsuccessful.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application.refreshFileListing

This function refreshes the file list in the Folder List panel.

Syntax

CopyCode image Copy Code
function xweb.application.refreshFileListing() : boolean

Parameters

None.

Returns

true The file list was successfully refreshed.

false The file list was not refreshed.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application.setActiveDocument

This function switches the active tab in Microsoft Expression Web to the specified document.

Syntax

CopyCode image Copy Code
function xweb.application.setActiveDocument(
document : document
) : boolean

Parameters

document The name of the document to be activated.

Returns

true The specified document was set to active.

false The specified document was not set to active.

See Also

Concepts

xweb.document
xweb.developer
xweb.developer Members
xweb


xweb.application.setPanelVisibility

This function changes the visibility state of the specified floating panel.

Note Note:

If the specified panel is docked but obscured by another panel, this function will not bring the specified panel to the front.

Syntax

CopyCode image Copy Code
function xweb.application.setPanelVisibility(
panelName : String,
state : String
) : boolean

Parameters

panelName The name of the panel whose visibility will be changed. If multiple panels have the same name, the visibility of the first programmatically encountered panel is changed.

state The desired panel visibility state. Legal values are visible and hidden.

Returns

true The visibility state of the specified panel is successfully changed.

false The visibility state of the specified panel is not changed.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application.showModalDialog

This function displays a modal dialog box.

Syntax

CopyCode image Copy Code
function xweb.application.showModalDialog(
source : String,
title : String,
features : String
) : Object

Parameters

source A string that specifies the URL of the document to load and display. Files in the add-in directory must be prefixed by addin:.

title The title to be displayed in the title bar of the modal dialog box; title cannot be null or the empty string ("").

features A string that specifies the window properties for the dialog box, using one or more of the following semicolon-delimited values:

  • dialogHeight: sHeight Sets the height of the dialog box window.

  • dialogWidth: sWidth Sets the width of the dialog box window.

  • resizable: { yes | no | 1 | 0 | on | off } Specifies whether the dialog box window has fixed dimensions. The default is no.

  • scroll:{ yes | no | 1 | 0 | on | off } Specifies whether the dialog box window displays scrollbars. The default is yes.

important note Note:

To work correctly with Windows display scaling, specify height and width values using em, rather than px, pt, or other absolute units of measure.

Returns

This function returns a modal dialog box.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application Properties

Public Properties

Name | Description
xweb.application.settings | Stores information that persists between sessions of Microsoft Expression Web, such as user preferences or other options defined in the add-in.
xweb.application.version | Returns the currently running version of Microsoft Expression Web, including minor version number or service pack number, as a string.

See Also

Concepts

xweb.application
xweb


xweb.application.settings

This property is used to allow an add-in to store information, such as user preferences, that persists over multiple Microsoft Expression Web sessions.

Syntax

CopyCode image Copy Code
function get xweb.application.settings() : settings

Parameters

None.

Returns

Nothing.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application.settings Members

The following table lists the members exposed by the xweb.application.settings object.

Public Members

Name | Description
xweb.application.settings.read | Reads an application setting.
xweb.application.settings.readConfig | Reads a group of application settings.
xweb.application.settings.write | Writes an application setting.
xweb.application.settings.writeConfig | Writes a group of application settings.

See Also

Concepts

xweb.application.settings
xweb.application
xweb


xweb.application.settings Methods

The following table lists the members exposed by the xweb.application.settings object.

Public Methods

Name | Description
xweb.application.settings.read | Reads an application setting.
xweb.application.settings.readConfig | Reads a group of application settings.
xweb.application.settings.write | Writes an application setting.
xweb.application.settings.writeConfig | Writes a group of application settings.

See Also

Concepts

xweb.application.settings
xweb.application
xweb


xweb.application.settings.read

This function retrieves a value associated with the add-in.

Syntax

CopyCode image Copy Code
function xweb.application.settings.read(
key : String
) : Object

Parameters

key The name of the value to be retrieved.

Returns

true The specified value was successfully retrieved.

false No value was retrieved.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application.settings.readConfig

This function retrieves a group of values associated with the add-in.

Syntax

CopyCode image Copy Code
function xweb.application.settings.readConfig(
key : String
config : String
) : Object

Parameters

key The group name of the values to be retrieved.

config An identifier that groups the value to be retrieved, such as a site name.

Returns

true The specified values were successfully retrieved.

false No values were retrieved.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application.settings.write

This function writes a value associated with the add-in.

Syntax

CopyCode image Copy Code
function xweb.application.settings.write(
key : String
) : Object

Parameters

key The name of the value to be written.

Returns

true The specified value was successfully written.

false No value was written.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application.settings.writeConfig

This function writes a group of values associated with the add-in.

Syntax

CopyCode image Copy Code
function xweb.application.settings.writeConfig(
key : String
config : String
) : Object

Parameters

key The name of the value to be written.

config An identifier that groups the value to be written, such as a site name.

Returns

true The specified values were successfully written.

false No values were written.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.application.version

This property returns the currently running version of Microsoft Expression Web, including minor version number or service pack number, as a string.

Syntax

CopyCode image Copy Code
function get xweb.application.version() : String

Parameters

None.

Returns

This property returns the currently running version of Expression Web, including minor version number or service pack number, as a string. It returns null if unsuccessful.

See Also

Concepts

xweb.application
xweb.application Members
xweb


xweb.developer

The xweb.developer object provides methods to write to the Debug Console to aid in debugging during the process of developing an add-in.

Syntax

JScript CopyCode image Copy Code
xweb.developer

Parameters

None.

Returns

Nothing.

See Also

Concepts

xweb.developer Members
xweb


xweb.developer Members

The following table lists the members exposed by the xweb.developer type.

Public Methods

Name | Description
xweb.developer.write | Sends the string argument to the Debug Console window.
xweb.developer.writeLine | Sends the string argument to the Debug Console window and includes a carriage return.

See Also

Concepts

xweb.developer
xweb


xweb.developer Methods

Public Methods

Name | Description
xweb.developer.write | Sends the string argument to the Debug Console window.
xweb.developer.writeLine | Sends the string argument to the Debug Console window and includes a carriage return.

See Also

Concepts

xweb.developer
xweb


xweb.developer.write

This function sends the string argument to the Debug Console window.

Syntax

CopyCode image Copy Code
function xweb.developer.write(
outputText : String
)

Parameters

outputText The string to write to the Debug Console window.

Returns

Nothing.

See Also

Concepts

xweb.developer
xweb.developer Members
xweb


xweb.developer.writeLine

This function sends the string argument to the Debug Console window and includes a carriage return.

Syntax

CopyCode image Copy Code
function xweb.developer.writeLine(
outputText : String
)

Parameters

outputText The string to write to the Debug Console window.

Returns

Nothing.

See Also

Concepts

xweb.developer
xweb.developer Members
xweb


xweb.document

The xweb.document object represents the active HTML document being edited in Microsoft Expression Web. The xweb.document properties and methods provide access to the contents of the active HTML document.

Syntax

JScript CopyCode image Copy Code
xweb.document

Parameters

None.

Returns

Nothing.

See Also

Concepts

xweb.document Members
xweb


xweb.document Members

The following tables list the members exposed by the xweb.document type.

Public Properties

Name Description

xweb.document.anchors

Returns an array of all the anchors in the current document.

xweb.document.applets

Returns an array of all the applets in the current document.

xweb.document.embeds

Returns an array of all the embed objects in the current document.

xweb.document.filename

Retrieves the file name of the current document, including the full path from the site root, and the file name extension.

xweb.document.forms

Returns an array of all the forms in the current document.

xweb.document.frames

Returns an array of all the frames in the current document.

xweb.document.htmlElement

Exposes the most common properties of HTML elements in the current document.

xweb.document.images

Returns an array of all the images in the current document.

xweb.document.htmlElement

Exposes the most common properties of valid HTML elements in an HTML document.

xweb.document.isXhtml

Retrieves the XHTML status of the document.

xweb.document.links

Returns an array of all the links in the current document.

xweb.document.location

Returns the absolute file path of the document from the drive root, as in the following example.

CopyCode image Copy Code
file:///C:\Users\UserName\Documents\My Web Sites\Example Site\example-file.html

xweb.document.name

Retrieves the file name of the document, including the file name extension.

xweb.document.pathFromSiteRoot

Retrieves the path of the current document, not including the document name.

xweb.document.scripts

Returns an array of all the scripts in the current document.

selection

Indicates the code within a document that has been selected.

Public Methods

Name | Description
xweb.document.appendScriptReference | Appends a <script> tag reference to the bottom of the head.
xweb.document.appendStyleReference | Appends a style sheet reference to the bottom of the head. If the exact reference exists, the function will not add a new reference.
xweb.document.close | Closes the document associated with a DOM.
xweb.document.getElementById | Returns the element that has the specified ID.
xweb.document.getElementsByAttributeName | Returns an array of objects that have the specified attribute attributeName.
xweb.document.getElementsByTagName | Returns an array of all the elements that contain the tag specified by tagName.
xweb.document.getScriptElementByCode | Searches the content of <script> tags and returns an htmlElement object that contains the specified code string.
xweb.document.getScriptElementByFile | Returns the element that has a <script> tag that contains the specified fileNamePattern.
xweb.document.getStyleElementByCode | Searches the content of <script> tags and returns an htmlElement object that contains the specified code string.
xweb.document.getStyleElementByFile | Searches the content of <style> tags and returns the htmlElement object that contains the specified code string.
xweb.document.insertBeforeHtml | Inserts a string before the <html> tag of the document.
xweb.document.save | Saves the file associated with a DOM.
xweb.document.saveAs | Opens the Save As dialog box to save the file associated with xweb.document.
xweb.document.synchronizeViews | Synchronizes the Microsoft Expression Web Design and Code views.

See Also

Concepts

xweb.document
xweb


xweb.document Methods

Public Methods

Name | Description
xweb.document.appendScriptReference | Appends a <script> tag reference to the bottom of the head.
xweb.document.appendStyleReference | Appends a style sheet reference to the bottom of the head. If the exact reference exists, the function will not add a new reference.
xweb.document.close | Closes the document associated with a DOM.
xweb.document.getElementById | Returns the element that has the specified ID.
xweb.document.getElementsByAttributeName | Returns an array of objects that have the specified attribute, attributeName.
xweb.document.getElementsByTagName | Returns an array of all the elements that contain the tag specified by tagName.
xweb.document.getScriptElementByCode | Searches the content of <script> tags and returns an htmlElement object that contains the specified code string.
xweb.document.getScriptElementByFile | Returns the element that has a <script> tag that contains the specified fileNamePattern.
xweb.document.getStyleElementByCode | Searches the content of <script> tags and returns an htmlElement object that contains the specified code string.
xweb.document.getStyleElementByFile | Searches the content of <style> tags and returns the htmlElement object that contains the specified code string.
xweb.document.insertBeforeHtml | Inserts a string before the <html> tag of the document.
xweb.document.save | Saves the file associated with a DOM.
xweb.document.saveAs | Opens the Save As dialog box to save the file associated with xweb.document.
xweb.document.synchronizeViews | Synchronizes the Microsoft Expression Web Design and Code views.

See Also

Concepts

xweb.document
xweb


xweb.document.appendScriptReference

This function appends a <script> tag reference to the bottom of the head. If the exact reference exists, the function will not add a new reference.

The script reference is in the following form.

CopyCode image Copy Code
<script type="text/type" src="filename.js">

Syntax

CopyCode image Copy Code
function xweb.document.appendScriptReference(
reference : String,
scriptType : String
) : boolean

Parameters

reference A string that contains the path and file name of the script file.

scriptType A string that specifies the script language, such as "javascript".

Returns

true The script reference was successfully added.

false The script reference was not added.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.appendStyleReference

This function appends a style sheet reference to the bottom of the head. If the exact reference exists, the function will not add a new reference.

The script reference is in the following form:

CopyCode image Copy Code
<link href="filename.css" rel="stylesheet" type="text/css" />

Syntax

CopyCode image Copy Code
function xweb.document.appendStyleReference(
reference : String
) : boolean

Parameters

reference A string that contains the path and file name of the style sheet file.

Returns

true The style sheet reference was successfully added.

false The style sheet reference was not added.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.close

This function closes the document associated with a DOM.

Syntax

CopyCode image Copy Code
function xweb.document.close() : boolean

Parameters

None.

Returns

true The document was successfully closed.

false The document was not closed.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.getElementById

This function returns the element that has the specified ID. If more than one element is found, only the first object is returned.

Syntax

CopyCode image Copy Code
function xweb.document.getElementById(
id : String
) : htmlElement

Parameters

id A string that contains the ID of the HTML element.

Returns

This function returns the htmlElement object that contains the specified id. If no matching element is found, undef is returned.

See Also

Concepts

xweb.document.htmlElement
xweb.document
xweb.document Members
xweb


xweb.document.getElementsByAttributeName

This function returns an array of objects that have the specified attribute attributeName.

Syntax

CopyCode image Copy Code
function xweb.document.getElementsByAttributeName(
attributeName : String
) : ArrayObject

Parameters

attributeName A string that contains the attribute name to search for.

Returns

This function returns the htmlElement object that contains the specified attributeName. If no matching element is found, an empty array is returned.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.getElementsByTagName

This function returns an array of all the elements that contain the tag specified by tagName. If more than one element is found, only the first element is returned.

Syntax

CopyCode image Copy Code
function xweb.document.getElementsByTagName(
tagName : String
) : ArrayObject

Parameters

tagName A string that contains the tag name to search for.

Returns

This function returns an array of the elements that contain the specified tagName. If no matching element is found, an empty array is returned.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.getScriptElementByCode

This function searches the content of <script> tags and returns an htmlElement object that contains the specified code string. If more than one matching element is found, only the first object is returned.

Syntax

CopyCode image Copy Code
function xweb.document.getScriptElementByCode(
code : String
) : htmlElement

Parameters

code A string that contains text that getScriptElementByCode will search for inside script blocks. The search is not case-sensitive.

Returns

This function returns the htmlElement object that contains the string specified by code. If no matching string is found, undef is returned.

See Also

Concepts

xweb.document.htmlElement
xweb.document
xweb.document Members
xweb


xweb.document.getScriptElementByFile

This function returns the element that has a <script> tag that contains the specified fileNamePattern. If more than one matching element is found, only the first object is returned.

Syntax

CopyCode image Copy Code
function xweb.document.getScriptElementByFile(
fileNamePattern : String
) : htmlElement

Parameters

fileNamePattern A string that contains the file name of the script to search for.

Returns

This function returns the htmlElement object that contains the specified fileNamePattern. If no matching element is found, undef is returned.

See Also

Concepts

xweb.document.htmlElement
xweb.document
xweb.document Members
xweb


xweb.document.getStyleElementByCode

This function searches the contents of <style> tags and returns the htmlElement object that contains the specified code string. If more than one matching element is found, only the first object is returned.

Syntax

CopyCode image Copy Code
function xweb.document.getStyleElementByCode(
code : String
) : htmlElement

Parameters

code A string that contains some or all of the text that getScriptElementByCode will search for inside <style> blocks. The search is not case-sensitive.

Returns

This function returns the htmlElement object that contains the string specified by code. If no matching string is found, undef is returned.

See Also

Concepts

xweb.document.htmlElement
xweb.document
xweb.document Members
xweb


xweb.document.getStyleElementByFile

This function returns the element that has a <link> tag that has fileNamePattern specified as the target. If more than one element is found, only the first object is returned.

Syntax

CopyCode image Copy Code
function xweb.document.getStyleElementByFile(
fileNamePattern : String
) : htmlElement

Parameters

fileNamePattern A string that contains the link target to search for.

Returns

This function returns the htmlElement object that contains the specified fileNamePattern. If no matching element is found, undef is returned.

See Also

Concepts

xweb.document.htmlElement
xweb.document
xweb.document Members
xweb


xweb.document.insertBeforeHtml

This function inserts a string before the <html> tag of the document.

Syntax

CopyCode image Copy Code
function xweb.document.insertBeforeHtml(
text : String)

Parameters

text A string that contains the text to be inserted.

Returns

true The text was successfully added.

false The text was not added.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.save

This function saves the file associated with a DOM.

Syntax

CopyCode image Copy Code
function xweb.document.save(
location : String
) : boolean

Parameters

location A string that contains the path of the save location, which must be within a defined site.

Returns

true The document was successfully saved.

false The document was not saved.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.saveAs

This function opens the Save As dialog box to save the file associated with xweb.document.

Syntax

CopyCode image Copy Code
function xweb.document.saveAs() : boolean

Parameters

None.

Returns

true The function was successful.

false The function was not successful.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.synchronizeViews

This function synchronizes the Microsoft Expression Web Design and Code views.

Syntax

CopyCode image Copy Code
function xweb.document.synchronizeViews() : boolean

Parameters

None.

Returns

true The Design and Code views were successfully synchronized.

false The Design and Code views were not synchronized.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document Properties

Public Properties

Name | Description
xweb.document.anchors | Returns an array of all the anchors in the current document.
xweb.document.applets | Returns an array of all the applets in the current document.
xweb.document.embeds | Returns an array of all the embed objects in the current document.
xweb.document.filename | Retrieves the file name of the current document, including the full path from the site root and the file name extension.
xweb.document.forms | Returns an array of all the forms in the current document.
xweb.document.frames | Returns an array of all the frames in the current document.
xweb.document.htmlElement | Exposes the most common properties of HTML elements in the current document.
xweb.document.images | Returns an array of all the images in the current document.
xweb.document.htmlElement | Exposes the most common properties of HTML elements in the current document.
xweb.document.isXhtml | Retrieves the XHTML status of the document.
xweb.document.links | Returns an array of all the links in the current document.
xweb.document.location | Returns the absolute file path of the document from the drive root, as in the following example: file:///C:\Users\UserName\Documents\My Web Sites\Example Site\example-file.html
xweb.document.name | Retrieves the file name of the document, including the file name extension.
xweb.document.pathFromSiteRoot | Retrieves the path of the current document, not including the document name.
xweb.document.scripts | Returns an array of all the scripts in the current document.
xweb.document.selection | Indicates the code within a document that has been selected.

See Also

Concepts

xweb.document
xweb


xweb.document.anchors

This property returns an array that contains all the anchors in the current document.

Syntax

CopyCode image Copy Code
function get xweb.document.anchors() : ArrayObject

Parameters

None.

Returns

This property returns an array that contains all the anchors in the current document.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.applets

This property returns an array of all the applets in the current document.

Syntax

CopyCode image Copy Code
function get xweb.document.applets() : ArrayObject

Parameters

None.

Returns

This property returns an array that contains all the applets in the current document.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.embeds

This property returns an array of all the embed objects in the current document.

Syntax

CopyCode image Copy Code
function get xweb.document.embeds() : ArrayObject

Parameters

None.

Returns

This property returns an array that contains all the embed objects in the current document.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.filename

This property retrieves the file name of the current document, including the full path from the site root, and the file name extension.

Syntax

CopyCode image Copy Code
function get xweb.document.fileName() : String

Parameters

None.

Returns

This property retrieves a string that contains the file name of the current document, including the full path from the site root, and the file name extension.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.forms

This property returns an array of all the forms in the current document.

Syntax

CopyCode image Copy Code
function get xweb.document.forms() : ArrayObject

Parameters

None.

Returns

This property returns an array that contains all the forms in the current document.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.frames

This property returns an array of all the frames in the current document.

Syntax

CopyCode image Copy Code
function get xweb.document.frames() : ArrayObject

Parameters

None.

Returns

This property returns an array that contains all the frames in the current document.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.htmlElement

The xweb.document.htmlElement object provides access to valid HTML elements in the active HTML document and exposes the most common properties of the selected HTML element.

Syntax

CopyCode image Copy Code
xweb.document.htmlElement

Parameters

None.

Returns

Nothing.

See Also

Concepts

xweb.document.htmlElement Members
xweb


xweb.document.htmlElement Members

The following tables list the members exposed by the xweb.document.htmlElement type.

Public Properties

Name | Description
xweb.document.htmlElement.childNodes | Returns an array containing the direct descendants of the specified element.
xweb.document.htmlElement.className | Retrieves the class name for the specified element.
xweb.document.htmlElement.id | Retrieves the ID for the specified element.
xweb.document.htmlElement.innerHtml | Sets or retrieves the HTML between the start and end tags of the specified element.
xweb.document.htmlElement.innerText | Retrieves the text between the start and end tags of the specified element.
xweb.document.htmlElement.nextSibling | Retrieves a reference to the next child of the parent for the specified element.
xweb.document.htmlElement.outerHtml | Sets or retrieves the specified element and its content in HTML.
xweb.document.htmlElement.parentNode | Retrieves the hierarchical parent of the specified element.
xweb.document.htmlElement.previousSibling | Retrieves a reference to the previous child of the parent for the specified element.
xweb.document.htmlElement.tagName | Retrieves the tag name for the specified element.

Public Methods

Name | Description
xweb.document.htmlElement.getAttribute | Retrieves the value of an attribute from the current element.
xweb.document.htmlElement.removeAttribute | Removes an attribute from the element.
xweb.document.htmlElement.setAttribute | Sets the value of the specified attribute.

See Also

Concepts

xweb.document.htmlElement
xweb


xweb.document.htmlElement Methods

Public Methods

Name | Description
xweb.document.htmlElement.getAttribute | Retrieves the value of an attribute from the current element.
xweb.document.htmlElement.removeAttribute | Removes an attribute from the current element.
xweb.document.htmlElement.setAttribute | Sets the value of the specified attribute.

See Also

Concepts

xweb.document.htmlElement
xweb


xweb.document.htmlElement.getAttribute

This method retrieves the value of an attribute from the current element.

Syntax

CopyCode image Copy Code
function xweb.document.htmlElement.getAttribute(
attributeName : String
) : String

Parameters

attributeName A string that specifies the attribute name to be retrieved. This parameter is required.

Returns

This method returns the value of the attribute as a string. If the attribute does not exist, null is returned.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement.removeAttribute

This function removes an attribute from the element.

Syntax

CopyCode image Copy Code
function xweb.document.htmlElement.removeAttribute(
attributeName : String
) : boolean

Parameters

attributeName A string that specifies the attribute name to be removed. This parameter is required.

Returns

true The specified attribute was successfully removed.

false The specified attribute was not removed.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement.setAttribute

This method sets the value of the specified attribute.

Syntax

CopyCode image Copy Code
function xweb.document.htmlElement.setAttribute(
attributeName : String,
value : String
) : boolean

Parameters

attributeName A string that specifies the attribute name. This parameter is required.

value A string that contains the attribute value to be set.

Returns

Nothing.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement Properties

Public Properties

Name | Description
xweb.document.htmlElement.childNodes | Returns an array containing the direct descendants of the specified element.
xweb.document.htmlElement.className | Retrieves the class name for the specified element.
xweb.document.htmlElement.id | Retrieves the ID for the specified element.
xweb.document.htmlElement.innerHtml | Sets or retrieves the HTML between the start and end tags of the specified element.
xweb.document.htmlElement.innerText | Retrieves the text between the start and end tags of the specified element.
xweb.document.htmlElement.nextSibling | Retrieves a reference to the next child of the parent for the specified element.
xweb.document.htmlElement.outerHtml | Sets or retrieves the specified element and its content in HTML.
xweb.document.htmlElement.parentNode | Retrieves the hierarchical parent of the specified element.
xweb.document.htmlElement.previousSibling | Retrieves a reference to the previous child of the parent for the specified element.
xweb.document.htmlElement.tagName | Retrieves the tag name for the specified element.

See Also

Concepts

xweb.document.htmlElement
xweb


xweb.document.htmlElement.childNodes

This property returns an array containing the direct descendants of the specified element. If the specified element has no children, this property returns a zero-length array.

Syntax

CopyCode image Copy Code
function get xweb.document.htmlElement.childNodes() : ArrayObject

Parameters

None.

Returns

This property returns an array containing the direct descendants of the specified element. If the specified element has no children, this property returns a zero-length array.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement.className

This property retrieves the class name for the specified element.

Syntax

CopyCode image Copy Code
function get xweb.document.htmlElement.className() : String

Parameters

None.

Returns

This property returns a string that contains the class name of the specified element.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement.id

This property retrieves the ID of the specified element.

Syntax

CopyCode image Copy Code
function get xweb.document.htmlElement.id() : String

Parameters

None.

Returns

This property returns a string that contains the ID of the specified element.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement.innerHtml

This property sets or retrieves the HTML between the start and end tags of the specified element.

Syntax

CopyCode image Copy Code
function get xweb.document.htmlElement.innerHtml() : String

function set xweb.document.htmlElement.innerHtml(value : String)

Parameters

value When used with set, the string to write between the start and end tags of the specified element. If there is existing text between the start and end tags, this operation will replace that text with the contents of the value string.

If the value string contains HTML tags, the string is parsed and formatted when it is added to the document.

Note Note:

Changes written to the document using innerHtml cause the DOM to be refreshed.

Returns

When used with get, this property returns the string contained within the start and end tags of the specified element.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement.innerText

This property sets or retrieves the text between the start and end tags of the specified element.

Syntax

CopyCode image Copy Code
function get xweb.document.htmlElement.innerText() : String

function set xweb.document.htmlElement.innerText(value : String)

Parameters

value When used with set, the string to write between the start and end tags of the specified element. If there is existing text between the start and end tags, this operation will replace that text with the contents of the value string.

Note Note:

Changes written to the document using innerText cause the DOM to be refreshed.

Returns

When used with get, this property returns the text contained between the start and end tags of the specified element.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement.nextSibling

This property retrieves a reference to the next child of the parent for the specified element.

Syntax

CopyCode image Copy Code
function get xweb.document.htmlElement.nextSibling() : htmlElement Object

Parameters

None.

Returns

This property returns a reference to the next object within the same node of the DOM tree as specified htmlElement.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement.outerHtml

This function sets or retrieves the specified element and its content in HTML.

Syntax

CopyCode image Copy Code
function get xweb.document.htmlElement.outerHtml() : String

function set xweb.document.htmlElement.outerHtml(value : String)

Parameters

value When used with set, the value string completely replaces the specified element, including the start and end tags.

If the value string contains HTML tags, the string is parsed and formatted when it is added to the document.

Note Note:

Changes written to the document using outerHtml cause the DOM to be refreshed.

Returns

When used with get, this property returns the string of the specified element, including the start and end tags that enclose the element.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement.parentNode

This function retrieves the hierarchical parent of the specified element.

Syntax

CopyCode image Copy Code
function get xweb.document.htmlElement.parentNode() : htmlElement Object

Parameters

None.

Returns

This function returns a reference to the object that defines the node of the DOM tree that contains the specified htmlElement.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement.previousSibling

This property retrieves a reference to the previous child of the parent for the specified element.

Syntax

CopyCode image Copy Code
function get xweb.document.htmlElement.previousSibling() : htmlElement Object

Parameters

None.

Returns

This property returns a reference to the previous object within the same node of the DOM tree as specified by htmlElement.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.htmlElement.tagName

This property retrieves the tag name of the specified element.

Syntax

CopyCode image Copy Code
function get xweb.document.htmlElement.tagName() : String

Parameters

None.

Returns

This property returns a string that contains the tag name of the specified element.

See Also

Concepts

xweb.document.htmlElement
xweb.document.htmlElement Members
xweb


xweb.document.images

This property returns an array of all the images in the current document.

Syntax

CopyCode image Copy Code
function get xweb.document.images() : ArrayObject

Parameters

None.

Returns

This property returns an array that contains all the images in the current document.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.isXhtml

This property retrieves the XHTML status of the document.

Syntax

CopyCode image Copy Code
function get xweb.document.isXhtml() : boolean

Parameters

None.

Returns

true The document is XHTML.

false The document is not XHTML.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.links

This property returns an array of all the links in the current document.

Syntax

CopyCode image Copy Code
function get xweb.document.links() : ArrayObject

Parameters

None.

Returns

This property returns an array that contains all the links in the current document.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.location

This property returns the absolute file path of the document from the drive root, as in the following example:

file:///C:\Users\UserName\Documents\My Web Sites\Example Site\example-file.html

Syntax

CopyCode image Copy Code
function get xweb.document.location() : IHTMLLocation

Parameters

None.

Returns

This property returns an IHTMLLocation object that specifies the location of the current document.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.name

This property retrieves the file name of the document, including the file name extension.

Syntax

CopyCode image Copy Code
function get xweb.document.name() : String

Parameters

None.

Returns

This property returns a string that contains the file name of the document, including the file name extension.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.pathFromSiteRoot

This property retrieves the path of the current document, not including the document name.

Note Note:

You can use the value of the pathFromSiteRoot property to construct relative paths to other assets in the site folder.

Syntax

CopyCode image Copy Code
function get xweb.document.pathFromSiteRoot() : String

Parameters

None.

Returns

This property retrieves a string that contains the path of the current document, not including the document name.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.scripts

This property returns an array of all the scripts in the current document.

Syntax

CopyCode image Copy Code
function get xweb.document.scripts() : ArrayObject

Parameters

None.

Returns

This property returns an array that contains all the scripts in the current document.

See Also

Concepts

xweb.document
xweb.document Members
xweb


xweb.document.selection

This property indicates the code within a document that has been selected.

Syntax

JScript CopyCode image Copy Code
function get selection() : selection

Parameters

None.

Returns

This property returns the selection() range for the portion of the document that is selected.

For more information, see xweb.document.selection.

See Also

Concepts

xweb.document.selection Members
xweb.document
xweb


xweb.document.selection Members

The following tables list the members exposed by the xweb.document.selection type.

Public Properties

Name | Description
xweb.document.selection.end | Indicates the ending character of the current selection, as measured by the number of characters from the beginning of the file as shown in Code view.
xweb.document.selection.start | Indicates the starting character of the current selection, as measured by the number of characters from the beginning of the file as shown in Code view.
xweb.document.selection.text | Indicates the characters encompassed by the current selection.

Public Methods

Name | Description
xweb.document.selection.append | Inserts a string at the end of the current selection.
xweb.document.selection.insert | Inserts a string at the beginning of the current selection.
xweb.document.selection.set | Sets the current selection range.
xweb.document.selection.remove | Deletes the current selection range.
xweb.document.selection.replace | Replaces the current selection range with the replacement string.
xweb.document.selection.wrap | Inserts the before string at the beginning the current selection and the after string at the end of the current selection. The function then selects the entire range, including the inserted tags.

See Also

Concepts

xweb


xweb.document.selection Methods

Public Methods

Name | Description
xweb.document.selection.append | Inserts a string at the end of the current selection.
xweb.document.selection.insert | Inserts a string at the beginning of the current selection.
xweb.document.selection.set | Sets the current selection range.
xweb.document.selection.remove | Deletes the current selection range.
xweb.document.selection.replace | Replaces the current selection range with the replacement string.
xweb.document.selection.wrap | Inserts the before string at the beginning the current selection and the after string at the end of the current selection. The function then selects the entire range, including the inserted tags.

See Also

Concepts

xweb.document.selection
xweb


xweb.document.selection.append

This function inserts a string at the end of the current selection.

Syntax

CopyCode image Copy Code
function xweb.document.selection.append(
text : String
) : boolean

Parameters

text The string to insert at the end of the current selection range.

Returns

true the string was successfully appended to the selected range.

false the string was not appended to the selected range.

See Also

Concepts

xweb.document.selection
xweb.document.selection Members
xweb


xweb.document.selection.insert

This function inserts a string at the beginning of the current selection.

Syntax

CopyCode image Copy Code
function xweb.document.selection.insert(
text : String
) : boolean

Parameters

text The string to be inserted at the beginning of the current selection range.

Returns

true the string was successfully inserted.

false the string was not inserted.

See Also

Concepts

xweb.document.selection
xweb.document.selection Members
xweb


xweb.document.selection.set

This function sets the current selection range.

Syntax

CopyCode image Copy Code
function xweb.document.selection.set(
start : int,
end : int
) : boolean

Parameters

start The location of the start of the selection, expressed as characters from the beginning of the document.

end The location of the end of the selection, expressed as characters from the beginning of the document.

Returns

true the selection was successfully set.

false the selection was not set

See Also

Concepts

xweb.document.selection
xweb.document.selection Members
xweb


xweb.document.selection.remove

This function deletes the current selection range.

Syntax

CopyCode image Copy Code
function xweb.document.selection.remove() : boolean

Parameters

None.

Returns

true the selected range was deleted.

false the selected range was not deleted.

See Also

Concepts

xweb.document.selection
xweb.document.selection Members
xweb


xweb.document.selection.replace

This function replaces the current selection range with the replacement string.

Syntax

CopyCode image Copy Code
function xweb.document.selection.replace(
text : String
) : boolean

Parameters

start The string that replaces the current selection range.

Returns

true the selected range was replaced and the insertion point was moved to the end of the replacement string.

false the selected range was not replaced.

See Also

Concepts

xweb.document.selection
xweb.document.selection Members
xweb


xweb.document.selection.wrap

This function inserts the before string at the beginning of the current selection and the after string at the end of the current selection. The function then selects the entire range, including the inserted tags.

Syntax

CopyCode image Copy Code
function xweb.document.selection.wrap(
before : String,
after : String
) : boolean

Parameters

before The string to insert at the beginning of the current selection range.

after The string to insert at the end of the current selection range.

Returns

Nothing.

See Also

Concepts

xweb.document.selection
xweb.document.selection Members
xweb


xweb.document.selection Properties

Public Properties

Name | Description
xweb.document.selection.end | Indicates the ending character of the current selection, as measured by the number of characters from the beginning of the file as shown in Code view.
xweb.document.selection.start | Indicates the starting character of the current selection, as measured by the number of characters from the beginning of the file as shown in Code view.
xweb.document.selection.text | Indicates the characters encompassed by the current selection.

See Also

Concepts

xweb


xweb.document.selection.start

This property indicates the starting character of the current selection, as measured by the number of characters from the beginning of the file as shown in Code view.

This property is read-only.

Syntax

CopyCode image Copy Code
public function get xweb.document.selection.start() : int

Parameters

None.

Returns

This property returns the starting character of the current selection, as measured by the number of characters from the beginning of the file as shown in Code view.

See Also

Concepts

xweb.document.selection
xweb.document.selection Members
xweb


xweb.document.selection.end

This property indicates the ending character of the current selection, as measured by the number of characters from the beginning of the file as shown in Code view.

This property is read-only.

Syntax

CopyCode image Copy Code
function get xweb.document.selection.end() : int

Parameters

None.

Returns

This property returns the ending character of the current selection, as measured by the number of characters from the beginning of the file as shown in Code view.

See Also

Concepts

xweb.document.selection
xweb.document.selection Members
xweb


xweb.document.selection.text

This property indicates the characters encompassed by the current selection. You can add text at the selection point by using the selection.append method.

For more information, see xweb.document.selection.append.

This is a read-write property.

Syntax

CopyCode image Copy Code
function get xweb.document.selection.text() : String
function set xweb.document.selection.text(value : String)

Parameters

value When used with set, value is the string to be written to the selection.

important note Note:

The selected text will be overwritten by the text in value.

Returns

When used with get, this property returns a string that contains the selected text.

See Also

Concepts

xweb.document.selection
xweb.document.selection Members
xweb


xweb.file

The xweb.file object provides methods for accessing files within a site directory or the "addins" directory. Because these methods generally treat files as a collection of characters, they are better suited for manipulating files that are not structured by a Document Object Model (DOM), such as Cascading Style Sheets (CSS), as opposed to files that use a DOM structure, such as HTML files.

To manipulate DOM-structured files, use the methods in xweb.document.

Syntax

JScript CopyCode image Copy Code
xweb.file

See Also

Concepts

xweb.file Members
xweb


xweb.file Members

The following table lists the members exposed by the xweb.file type.

Public Methods

Name | Description
xweb.file.copy | Copies one or more files from the source location to the destination location.
xweb.file.createFile | Creates a file at the specified location.
xweb.file.createFolder | Creates a folder at the specified location.
xweb.file.deleteFile | Deletes the specified file.
xweb.file.exists | Tests for the existence of the specified file.
xweb.file.getAttribute | Gets the attributes of the specified file or folder.
xweb.file.getCreationDate | Gets the JavaScript object that represents the time when the file was created.
xweb.file.getModificationDate | Gets the JavaScript date object that represents the time when the file was last modified.
xweb.file.getSize | Gets the size of a specified file.
xweb.file.listFolder | Gets a list of the contents of the specified folder.
xweb.file.read | Reads the contents of the specified file into a string.
xweb.file.setAttributes | Sets the attributes of the specified file or folder.
xweb.file.write | Writes the specified string to the specified file. If the specified file does not yet exist, it is created.

See Also

Concepts

xweb.file
xweb


xweb.file Methods

Public Methods

Name | Description
xweb.file.copy | Copies one or more files from the source location to the destination location.
xweb.file.createFile | Creates a file at the specified location.
xweb.file.createFolder | Creates a folder at the specified location.
xweb.file.deleteFile | Deletes the specified file.
xweb.file.exists | Tests for the existence of the specified file.
xweb.file.getAttribute | Gets the attributes of the specified file or folder.
xweb.file.getCreationDate | Gets the JavaScript object that represents the time when the file was created.
xweb.file.getModificationDate | Gets the JavaScript date object that represents the time when the file was last modified.
xweb.file.getSize | Gets the size of a specified file.
xweb.file.listFolder | Gets a list of the contents of the specified folder.
xweb.file.read | Reads the contents of the specified file into a string.
xweb.file.setAttributes | Sets the attributes of the specified file or folder.
xweb.file.write | Writes the specified string to the specified file. If the specified file does not yet exist, it is created.

See Also

Concepts

xweb.file
xweb


xweb.file.copy

This function copies one or more files from the source location to the destination location.

Syntax

CopyCode image Copy Code
function xweb.file.copy(
source : String,
destination : String,
overwrite : boolean
) : boolean

Parameters

source The file to be copied, expressed as a site or add-in URI argument. Files within the site must be prefixed by site:, and files within the add-in folder must be prefixed by addin:.

destination The location to which the file will be copied. The destination location must be within the site directory.

overwrite A Boolean value that specifies whether to overwrite an existing destination file. Possible values include the following:

  • true Overwrite the destination file (default).

  • false Do not overwrite the destination file.

Returns

true The specified file was successfully copied.

false No file was copied.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.createFile

This function creates a file at the specified location.

Syntax

CopyCode image Copy Code
function xweb.file.createFile(
path : String
) : boolean

Parameters

path The location of the file, which must be within the site. Must be prefixed by site:.

Returns

true The specified file was successfully created.

false No file was created.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.createFolder

This function creates a folder at the specified location.

Syntax

CopyCode image Copy Code
function xweb.file.createFolder(
path : String
) : boolean

Parameters

path The location of the folder to be created, which must be within the site. The path location must be prefixed by site:.

Returns

true The specified folder was successfully created.

false No folder was created.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.deleteFile

This function deletes the specified file.

Syntax

CopyCode image Copy Code
function xweb.file.deleteFile(
path : String
) : boolean

Parameters

path The location of the file, which must be within the site. Must be prefixed by site:.

Returns

true The file successfully deleted.

false The file was not deleted.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.exists

This function tests for the existence of the specified file.

Syntax

CopyCode image Copy Code
function xweb.file.exists(
path : String
) : boolean

Parameters

path The location of the file, which must be within the site. The path location must be prefixed by site:.

Returns

true The specified file exists.

false The specified file does not exist.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.getAttribute

This function gets the attributes of the specified file or folder.

Syntax

CopyCode image Copy Code
function xweb.file.getAttribute(
path : String
) : String

Parameters

path A site or add-in URI argument. Files within the site must be prefixed by site:, and files within the add-in folder must be prefixed by addin:.

Returns

attributes A string that represents the attributes of the specified file or folder. Valid attributes are as follows:

  • R Specifies that the file or folder is read-only.

  • D Specifies that the object is a folder.

  • H Specifies that the file or folder is hidden.

  • S Specifies that the object is a system file or a system folder.

  • null Specifies that the specified file or folder does not exist.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.getCreationDate

This function retrieves the JavaScript object that represents the date and time when the file was created.

Syntax

CopyCode image Copy Code
function xweb.file.getCreationDate(
path : String
) : Object

Parameters

path The location of the file within the site or the add-in folder. If the file is within the site folder, the path must be prefixed by site:. If the file is within the add-in folder, the path must be prefixed by addin:.

Returns

This function returns a JavaScript Date object that contains the date and time that the specified file was created.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.getModificationDate

This function gets the JavaScript date object that represents the time when the file was last modified.

Syntax

CopyCode image Copy Code
function xweb.file.getModificationDate(
path : String
) : Object

Parameters

path The location of the file or folder.

Folders within the site must be prefixed by site:. Folders within the add-in folder must be prefixed by addin:.

Returns

This function returns a JavaScript date object that represents the date and time when the specified file was last modified. It returns null if unsuccessful.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.getSize

This function gets the size of a specified file.

Syntax

CopyCode image Copy Code
function xweb.file.getSize(
path : String
) : long

Parameters

path A site or add-in URI argument. Files within the site must be prefixed by site:, and files within the add-in folder must be prefixed by addin:.

Returns

This function returns an integer that represents the size of the specified file in bytes. It returns -1 if it is unsuccessful.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.listFolder

This function gets a list of the contents of the specified folder.

Syntax

CopyCode image Copy Code
function xweb.file.listFolder(
folder : String,
constraint : String
) : ArrayObject

Parameters

folder The location of the folder, which may include the following wildcard characters:

  • * Matches one or more characters.

  • ? Matches a single character.

Folders within the site must be prefixed by site:. Folders within the add-in folder must be prefixed by addin:.

constraint An optional parameter that limits the return results as follows:

  • files Returns only the files within the specified folder.

  • folders Returns only the subfolders of the specified folder.

If no constraint parameter is specified, the function returns both files and folders.

Returns

This function returns a string array that contains the list of objects in the specified folder.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.read

This function reads the contents of the specified file into a string.

Syntax

CopyCode image Copy Code
function xweb.file.read(
path : String
) : String

Parameters

path The location of the file, which must be within the site. Must be prefixed by site:.

Returns

This function returns a string that contains the contents of the file.

If the file is empty or the read operation was unsuccessful, this function returns null.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.setAttributes

This function sets the attributes of the specified file or folder.

Syntax

CopyCode image Copy Code
function xweb.file.setAttributes(
path : String,
attributes : String
) : boolean

Parameters

path A site or add-in URI argument. Files within the site must be prefixed by site:, and files within the add-in folder must be prefixed by addin:.

attributes A string that represents the attributes of the specified file or folder. Valid attributes are as follows:

  • R Specifies that the file or folder is read-only.

  • D Specifies that the object is a folder.

  • H Specifies that the file or folder is hidden.

  • S Specifies that the object is system file or folder.

Returns

Nothing.

See Also

Concepts

xweb.file
xweb.file Members
xweb


xweb.file.write

This function writes the specified string to the specified file. If the specified file does not yet exist, it is created.

Syntax

CopyCode image Copy Code
function xweb.file.write(
path : String,
contents : String,
mode : String
) : boolean

Parameters

path The location of the file, which must be within the site. Must be prefixed by site:.

contents The string to be written to the specified file.

mode Optional. The only value for the mode parameter is append, which adds the contents string to the end of the specified file. If the mode parameter is not specified, the contents of the specified file are overwritten.

Returns

true The contents string was successfully written to the file.

false The write was not successful.

See Also

Concepts

xweb.file
xweb.file Members
xweb


Class Library

Namespaces

Namespace
Microsoft.Expression.Web


Microsoft.Expression.Web Namespace

Classes

Class | Description
EventArgs |
SiteDataService |
SystemColorWorkaround | This type is a copy of SystemColors with some modifications that remove the caching.
ToolBarDescription |
XWebApplication | Implements the main application class.

Interfaces

Interface | Description
ISiteDataService |
IToolBarDescription |


EventArgs Generic Class
See Also Members
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Class EventArgs(Of TArgType)
    Inherits EventArgs
Visual Basic (Usage)
Dim instance As EventArgs(Of TArgType)
C#
public class EventArgs<TArgType> : EventArgs
C++
generic<typename TArgType>
public ref class EventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.Expression.Web.EventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

EventArgs Members
Microsoft.Expression.Web Namespace


EventArgs Members
See Also Constructors Fields Methods Properties
[image]

The following tables list the members exposed by the EventArgs type.

Public Constructors

Name | Description
EventArgs |
Top

Public Fields

Name | Description
Empty | (Inherited from EventArgs)
Top

Public Properties

Name | Description
Argument |
Top

Public Methods (see also Protected Methods)

Name | Description
Equals | Overloaded. (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ReferenceEquals | (Inherited from Object)
ToString | (Inherited from Object)
Top

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)
Top

See Also

Reference

EventArgs Generic Class


EventArgs Fields
See Also
[image]

Public Fields

Name | Description
Empty | (Inherited from EventArgs)

See Also

Reference

EventArgs Generic Class


EventArgs Constructor
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
Visual Basic (Usage)
Dim instance As New EventArgs(Of TArgType)
C#
public EventArgs ()
C++
public:
EventArgs ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

EventArgs Generic Class
EventArgs Members


EventArgs Methods
See Also
[image]

Public Methods (see also Protected Methods)

Name | Description
Equals | Overloaded. (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ReferenceEquals | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

See Also

Reference

EventArgs Generic Class


EventArgs Properties
See Also
[image]

Public Properties

Name | Description
Argument |

See Also

Reference

EventArgs Generic Class


EventArgs.Argument Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Property Argument As TArgType
Visual Basic (Usage)
Dim instance As EventArgs(Of TArgType)
Dim value As TArgType

value = instance.Argument

instance.Argument = value
C#
public TArgType Argument { get; set; }
C++
public:
property TArgType Argument {
    TArgType get ();
    void set (TArgType value);
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

EventArgs Generic Class
EventArgs Members


ISiteDataService Interface
See Also Members
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Interface ISiteDataService
Visual Basic (Usage)
Dim instance As ISiteDataService
C#
public interface ISiteDataService
C++
public interface class ISiteDataService

See Also

Reference

ISiteDataService Members


ISiteDataService Members
See Also Methods Properties
[image]

The following tables list the members exposed by the ISiteDataService type.

Public Properties

Name | Description
CurrentConfigurationService |
CurrentSiteName |
SiteCount |
SiteNames |
Top

Public Methods

Name | Description
Add |
CloseSite |
DeleteSite |
LoadSite |
RenameSite |
TempConfigurationService |
Top

See Also

Reference

ISiteDataService Interface


ISiteDataService Methods
See Also
[image]

Public Methods

Name | Description
Add |
CloseSite |
DeleteSite |
LoadSite |
RenameSite |
TempConfigurationService |

See Also

Reference

ISiteDataService Interface


ISiteDataService.Add Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Function Add ( _
    siteName As String _
) As IConfigurationService
Visual Basic (Usage)
Dim instance As ISiteDataService
Dim siteName As String
Dim returnValue As IConfigurationService

returnValue = instance.Add(siteName)
C#
IConfigurationService Add (
    string siteName
)
C++
IConfigurationService^ Add (
    String^ siteName
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ISiteDataService Interface
ISiteDataService Members


ISiteDataService.CloseSite Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Sub CloseSite
Visual Basic (Usage)
Dim instance As ISiteDataService

instance.CloseSite
C#
void CloseSite ()
C++
void CloseSite ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ISiteDataService Interface
ISiteDataService Members


ISiteDataService.DeleteSite Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Function DeleteSite ( _
    siteName As String _
) As Boolean
Visual Basic (Usage)
Dim instance As ISiteDataService
Dim siteName As String
Dim returnValue As Boolean

returnValue = instance.DeleteSite(siteName)
C#
bool DeleteSite (
    string siteName
)
C++
bool DeleteSite (
    String^ siteName
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ISiteDataService Interface
ISiteDataService Members


ISiteDataService.LoadSite Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Function LoadSite ( _
    siteName As String _
) As IConfigurationService
Visual Basic (Usage)
Dim instance As ISiteDataService
Dim siteName As String
Dim returnValue As IConfigurationService

returnValue = instance.LoadSite(siteName)
C#
IConfigurationService LoadSite (
    string siteName
)
C++
IConfigurationService^ LoadSite (
    String^ siteName
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ISiteDataService Interface
ISiteDataService Members


ISiteDataService.RenameSite Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Function RenameSite ( _
    siteOldName As String, _
    siteNewName As String _
) As Boolean
Visual Basic (Usage)
Dim instance As ISiteDataService
Dim siteOldName As String
Dim siteNewName As String
Dim returnValue As Boolean

returnValue = instance.RenameSite(siteOldName, siteNewName)
C#
bool RenameSite (
    string siteOldName,
    string siteNewName
)
C++
bool RenameSite (
    String^ siteOldName,
    String^ siteNewName
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ISiteDataService Interface
ISiteDataService Members


ISiteDataService.TempConfigurationService Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Function TempConfigurationService ( _
    siteName As String _
) As IConfigurationService
Visual Basic (Usage)
Dim instance As ISiteDataService
Dim siteName As String
Dim returnValue As IConfigurationService

returnValue = instance.TempConfigurationService(siteName)
C#
IConfigurationService TempConfigurationService (
    string siteName
)
C++
IConfigurationService^ TempConfigurationService (
    String^ siteName
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ISiteDataService Interface
ISiteDataService Members


ISiteDataService Properties
See Also
[image]

Public Properties

Name | Description
CurrentConfigurationService |
CurrentSiteName |
SiteCount |
SiteNames |

See Also

Reference

ISiteDataService Interface


ISiteDataService.CurrentConfigurationService Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CurrentConfigurationService As IConfigurationService
Visual Basic (Usage)
Dim instance As ISiteDataService
Dim value As IConfigurationService

value = instance.CurrentConfigurationService
C#
IConfigurationService CurrentConfigurationService { get; }
C++
property IConfigurationService^ CurrentConfigurationService {
    IConfigurationService^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ISiteDataService Interface
ISiteDataService Members


ISiteDataService.CurrentSiteName Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CurrentSiteName As String
Visual Basic (Usage)
Dim instance As ISiteDataService
Dim value As String

value = instance.CurrentSiteName
C#
string CurrentSiteName { get; }
C++
property String^ CurrentSiteName {
    String^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ISiteDataService Interface
ISiteDataService Members


ISiteDataService.SiteCount Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SiteCount As Integer
Visual Basic (Usage)
Dim instance As ISiteDataService
Dim value As Integer

value = instance.SiteCount
C#
int SiteCount { get; }
C++
property int SiteCount {
    int get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ISiteDataService Interface
ISiteDataService Members


ISiteDataService.SiteNames Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SiteNames As Collection(Of String)
Visual Basic (Usage)
Dim instance As ISiteDataService
Dim value As Collection(Of String)

value = instance.SiteNames
C#
Collection<string> SiteNames { get; }
C++
property Collection<String^>^ SiteNames {
    Collection<String^>^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ISiteDataService Interface
ISiteDataService Members


IToolBarDescription Interface
See Also Members
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Interface IToolBarDescription
Visual Basic (Usage)
Dim instance As IToolBarDescription
C#
public interface IToolBarDescription
C++
public interface class IToolBarDescription

See Also

Reference

IToolBarDescription Members


IToolBarDescription Members
See Also Properties
[image]

The following tables list the members exposed by the IToolBarDescription type.

Public Properties

Name | Description
Name |
Visible |
Top

See Also

Reference

IToolBarDescription Interface


IToolBarDescription Properties
See Also
[image]

Public Properties

Name | Description
Name |
Visible |

See Also

Reference

IToolBarDescription Interface


IToolBarDescription.Name Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Property Name As String
Visual Basic (Usage)
Dim instance As IToolBarDescription
Dim value As String

value = instance.Name

instance.Name = value
C#
string Name { get; set; }
C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

IToolBarDescription Interface
IToolBarDescription Members


IToolBarDescription.Visible Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Property Visible As Boolean
Visual Basic (Usage)
Dim instance As IToolBarDescription
Dim value As Boolean

value = instance.Visible

instance.Visible = value
C#
bool Visible { get; set; }
C++
property bool Visible {
    bool get ();
    void set (bool value);
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

IToolBarDescription Interface
IToolBarDescription Members


SiteDataService Class
See Also Members
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Class SiteDataService
    Implements ISiteDataService
Visual Basic (Usage)
Dim instance As SiteDataService
C#
public class SiteDataService : ISiteDataService
C++
public ref class SiteDataService : ISiteDataService

Inheritance Hierarchy

System.Object
Microsoft.Expression.Web.SiteDataService

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Members


SiteDataService Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the SiteDataService type.

Public Constructors

Name | Description
SiteDataService |
Top

Public Properties

Name | Description
CurrentConfigurationService |
CurrentSiteName |
SiteCount |
SiteNames |
Top

Public Methods (see also Protected Methods)

Name | Description
Add |
CloseSite |
DeleteSite |
Equals | Overloaded. (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
LoadSite |
ReferenceEquals | (Inherited from Object)
RenameSite |
TempConfigurationService |
ToString | (Inherited from Object)
Top

Protected Methods

Name | Description
CreateNewConfigurationService |
FileNameDecode |
FileNameEncode |
Finalize | (Inherited from Object)
FullConfigPath |
MemberwiseClone | (Inherited from Object)
Top

See Also

Reference

SiteDataService Class


SiteDataService Constructor
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
Visual Basic (Usage)
Dim instance As New SiteDataService
C#
public SiteDataService ()
C++
public:
SiteDataService ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService Methods
See Also
[image]

Public Methods (see also Protected Methods)

Name | Description
Add |
CloseSite |
DeleteSite |
Equals | Overloaded. (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
LoadSite |
ReferenceEquals | (Inherited from Object)
RenameSite |
TempConfigurationService |
ToString | (Inherited from Object)

Protected Methods

Name | Description
CreateNewConfigurationService |
FileNameDecode |
FileNameEncode |
Finalize | (Inherited from Object)
FullConfigPath |
MemberwiseClone | (Inherited from Object)

See Also

Reference

SiteDataService Class


SiteDataService.Add Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Add ( _
    siteName As String _
) As IConfigurationService
Visual Basic (Usage)
Dim instance As SiteDataService
Dim siteName As String
Dim returnValue As IConfigurationService

returnValue = instance.Add(siteName)
C#
public virtual IConfigurationService Add (
    string siteName
)
C++
public:
virtual IConfigurationService^ Add (
    String^ siteName
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.CloseSite Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Sub CloseSite
Visual Basic (Usage)
Dim instance As SiteDataService

instance.CloseSite
C#
public void CloseSite ()
C++
public:
virtual void CloseSite () sealed

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.CreateNewConfigurationService Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateNewConfigurationService ( _
    path As String _
) As IConfigurationService
Visual Basic (Usage)
Dim path As String
Dim returnValue As IConfigurationService

returnValue = Me.CreateNewConfigurationService(path)
C#
protected virtual IConfigurationService CreateNewConfigurationService (
    string path
)
C++
protected:
virtual IConfigurationService^ CreateNewConfigurationService (
    String^ path
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.DeleteSite Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function DeleteSite ( _
    siteName As String _
) As Boolean
Visual Basic (Usage)
Dim instance As SiteDataService
Dim siteName As String
Dim returnValue As Boolean

returnValue = instance.DeleteSite(siteName)
C#
public virtual bool DeleteSite (
    string siteName
)
C++
public:
virtual bool DeleteSite (
    String^ siteName
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.FileNameDecode Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function FileNameDecode ( _
    name As String _
) As String
Visual Basic (Usage)
Dim name As String
Dim returnValue As String

returnValue = Me.FileNameDecode(name)
C#
protected virtual string FileNameDecode (
    string name
)
C++
protected:
virtual String^ FileNameDecode (
    String^ name
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.FileNameEncode Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function FileNameEncode ( _
    name As String _
) As String
Visual Basic (Usage)
Dim name As String
Dim returnValue As String

returnValue = Me.FileNameEncode(name)
C#
protected virtual string FileNameEncode (
    string name
)
C++
protected:
virtual String^ FileNameEncode (
    String^ name
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.FullConfigPath Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function FullConfigPath As String
Visual Basic (Usage)
Dim returnValue As String

returnValue = Me.FullConfigPath
C#
protected virtual string FullConfigPath ()
C++
protected:
virtual String^ FullConfigPath ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.LoadSite Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Function LoadSite ( _
    siteName As String _
) As IConfigurationService
Visual Basic (Usage)
Dim instance As SiteDataService
Dim siteName As String
Dim returnValue As IConfigurationService

returnValue = instance.LoadSite(siteName)
C#
public IConfigurationService LoadSite (
    string siteName
)
C++
public:
virtual IConfigurationService^ LoadSite (
    String^ siteName
) sealed

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.RenameSite Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function RenameSite ( _
    siteOldName As String, _
    siteNewName As String _
) As Boolean
Visual Basic (Usage)
Dim instance As SiteDataService
Dim siteOldName As String
Dim siteNewName As String
Dim returnValue As Boolean

returnValue = instance.RenameSite(siteOldName, siteNewName)
C#
public virtual bool RenameSite (
    string siteOldName,
    string siteNewName
)
C++
public:
virtual bool RenameSite (
    String^ siteOldName,
    String^ siteNewName
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.TempConfigurationService Method
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Function TempConfigurationService ( _
    siteName As String _
) As IConfigurationService
Visual Basic (Usage)
Dim instance As SiteDataService
Dim siteName As String
Dim returnValue As IConfigurationService

returnValue = instance.TempConfigurationService(siteName)
C#
public IConfigurationService TempConfigurationService (
    string siteName
)
C++
public:
virtual IConfigurationService^ TempConfigurationService (
    String^ siteName
) sealed

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService Properties
See Also
[image]

Public Properties

Name | Description
CurrentConfigurationService |
CurrentSiteName |
SiteCount |
SiteNames |

See Also

Reference

SiteDataService Class


SiteDataService.CurrentConfigurationService Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrentConfigurationService As IConfigurationService
Visual Basic (Usage)
Dim instance As SiteDataService
Dim value As IConfigurationService

value = instance.CurrentConfigurationService
C#
public IConfigurationService CurrentConfigurationService { get; }
C++
public:
virtual property IConfigurationService^ CurrentConfigurationService {
    IConfigurationService^ get () sealed;
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.CurrentSiteName Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrentSiteName As String
Visual Basic (Usage)
Dim instance As SiteDataService
Dim value As String

value = instance.CurrentSiteName
C#
public string CurrentSiteName { get; }
C++
public:
virtual property String^ CurrentSiteName {
    String^ get () sealed;
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.SiteCount Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SiteCount As Integer
Visual Basic (Usage)
Dim instance As SiteDataService
Dim value As Integer

value = instance.SiteCount
C#
public int SiteCount { get; }
C++
public:
virtual property int SiteCount {
    int get () sealed;
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SiteDataService.SiteNames Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SiteNames As Collection(Of String)
Visual Basic (Usage)
Dim instance As SiteDataService
Dim value As Collection(Of String)

value = instance.SiteNames
C#
public virtual Collection<string> SiteNames { get; }
C++
public:
virtual property Collection<String^>^ SiteNames {
    Collection<String^>^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SiteDataService Class
SiteDataService Members


SystemColorWorkaround Class
See Also Members
[image]

This type is a copy of SystemColors with some modifications that remove the caching.

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SystemColorWorkaround
Visual Basic (Usage)
C#
public static class SystemColorWorkaround
C++
public ref class SystemColorWorkaround abstract sealed

Inheritance Hierarchy

System.Object
Microsoft.Expression.Web.SystemColorWorkaround

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Members


SystemColorWorkaround Members
See Also Methods Properties
[image]

The following tables list the members exposed by the SystemColorWorkaround type.

Public Properties

Name | Description
CurrentSystemColorsHash |
SystemActiveBorderBrush |
SystemActiveBorderColor |
SystemActiveCaptionBrush |
SystemActiveCaptionColor |
SystemActiveCaptionTextBrush |
SystemActiveCaptionTextColor |
SystemAppWorkspaceBrush |
SystemAppWorkspaceColor |
SystemControlBrush |
SystemControlColor |
SystemControlDarkBrush |
SystemControlDarkColor |
SystemControlDarkDarkBrush |
SystemControlDarkDarkColor |
SystemControlLightBrush |
SystemControlLightColor |
SystemControlLightLightBrush |
SystemControlLightLightColor |
SystemControlTextBrush |
SystemControlTextColor |
SystemDesktopBrush |
SystemDesktopColor |
SystemGradientActiveCaptionBrush |
SystemGradientActiveCaptionColor |
SystemGradientInactiveCaptionBrush |
SystemGradientInactiveCaptionColor |
SystemGrayTextBrush |
SystemGrayTextColor |
SystemHighlightBrush |
SystemHighlightColor |
SystemHighlightTextBrush |
SystemHighlightTextColor |
SystemHotTrackBrush |
SystemHotTrackColor |
SystemInactiveBorderBrush |
SystemInactiveBorderColor |
SystemInactiveCaptionBrush |
SystemInactiveCaptionColor |
SystemInactiveCaptionTextBrush |
SystemInactiveCaptionTextColor |
SystemInfoBrush |
SystemInfoColor |
SystemInfoTextBrush |
SystemInfoTextColor |
SystemMenuBarBrush |
SystemMenuBarColor |
SystemMenuBrush |
SystemMenuColor |
SystemMenuHighlightBrush |
SystemMenuHighlightColor |
SystemMenuTextBrush |
SystemMenuTextColor |
SystemScrollBarBrush |
SystemScrollBarColor |
SystemWindowBrush |
SystemWindowColor |
SystemWindowFrameBrush |
SystemWindowFrameColor |
SystemWindowTextBrush |
SystemWindowTextColor |
Top

Public Methods (see also Protected Methods)

Name | Description
Equals | Overloaded. (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ReferenceEquals | (Inherited from Object)
ToString | (Inherited from Object)
Top

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)
Top

See Also

Reference

SystemColorWorkaround Class


SystemColorWorkaround Methods
See Also
[image]

Public Methods (see also Protected Methods)

Name | Description
Equals | Overloaded. (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ReferenceEquals | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

See Also

Reference

SystemColorWorkaround Class


SystemColorWorkaround Properties
See Also
[image]

Public Properties

Name | Description
CurrentSystemColorsHash |
SystemActiveBorderBrush |
SystemActiveBorderColor |
SystemActiveCaptionBrush |
SystemActiveCaptionColor |
SystemActiveCaptionTextBrush |
SystemActiveCaptionTextColor |
SystemAppWorkspaceBrush |
SystemAppWorkspaceColor |
SystemControlBrush |
SystemControlColor |
SystemControlDarkBrush |
SystemControlDarkColor |
SystemControlDarkDarkBrush |
SystemControlDarkDarkColor |
SystemControlLightBrush |
SystemControlLightColor |
SystemControlLightLightBrush |
SystemControlLightLightColor |
SystemControlTextBrush |
SystemControlTextColor |
SystemDesktopBrush |
SystemDesktopColor |
SystemGradientActiveCaptionBrush |
SystemGradientActiveCaptionColor |
SystemGradientInactiveCaptionBrush |
SystemGradientInactiveCaptionColor |
SystemGrayTextBrush |
SystemGrayTextColor |
SystemHighlightBrush |
SystemHighlightColor |
SystemHighlightTextBrush |
SystemHighlightTextColor |
SystemHotTrackBrush |
SystemHotTrackColor |
SystemInactiveBorderBrush |
SystemInactiveBorderColor |
SystemInactiveCaptionBrush |
SystemInactiveCaptionColor |
SystemInactiveCaptionTextBrush |
SystemInactiveCaptionTextColor |
SystemInfoBrush |
SystemInfoColor |
SystemInfoTextBrush |
SystemInfoTextColor |
SystemMenuBarBrush |
SystemMenuBarColor |
SystemMenuBrush |
SystemMenuColor |
SystemMenuHighlightBrush |
SystemMenuHighlightColor |
SystemMenuTextBrush |
SystemMenuTextColor |
SystemScrollBarBrush |
SystemScrollBarColor |
SystemWindowBrush |
SystemWindowColor |
SystemWindowFrameBrush |
SystemWindowFrameColor |
SystemWindowTextBrush |
SystemWindowTextColor |

See Also

Reference

SystemColorWorkaround Class


SystemColorWorkaround.CurrentSystemColorsHash Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CurrentSystemColorsHash As Integer
Visual Basic (Usage)
Dim value As Integer

value = SystemColorWorkaround.CurrentSystemColorsHash
C#
public static int CurrentSystemColorsHash { get; }
C++
public:
static property int CurrentSystemColorsHash {
    int get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemActiveBorderBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemActiveBorderBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemActiveBorderBrush
C#
public static SolidColorBrush SystemActiveBorderBrush { get; }
C++
public:
static property SolidColorBrush^ SystemActiveBorderBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemActiveBorderColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemActiveBorderColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemActiveBorderColor
C#
public static Color SystemActiveBorderColor { get; }
C++
public:
static property Color SystemActiveBorderColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemActiveCaptionBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemActiveCaptionBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemActiveCaptionBrush
C#
public static SolidColorBrush SystemActiveCaptionBrush { get; }
C++
public:
static property SolidColorBrush^ SystemActiveCaptionBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemActiveCaptionColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemActiveCaptionColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemActiveCaptionColor
C#
public static Color SystemActiveCaptionColor { get; }
C++
public:
static property Color SystemActiveCaptionColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemActiveCaptionTextBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemActiveCaptionTextBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemActiveCaptionTextBrush
C#
public static SolidColorBrush SystemActiveCaptionTextBrush { get; }
C++
public:
static property SolidColorBrush^ SystemActiveCaptionTextBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemActiveCaptionTextColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemActiveCaptionTextColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemActiveCaptionTextColor
C#
public static Color SystemActiveCaptionTextColor { get; }
C++
public:
static property Color SystemActiveCaptionTextColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemAppWorkspaceBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemAppWorkspaceBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemAppWorkspaceBrush
C#
public static SolidColorBrush SystemAppWorkspaceBrush { get; }
C++
public:
static property SolidColorBrush^ SystemAppWorkspaceBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemAppWorkspaceColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemAppWorkspaceColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemAppWorkspaceColor
C#
public static Color SystemAppWorkspaceColor { get; }
C++
public:
static property Color SystemAppWorkspaceColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemControlBrush
C#
public static SolidColorBrush SystemControlBrush { get; }
C++
public:
static property SolidColorBrush^ SystemControlBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemControlColor
C#
public static Color SystemControlColor { get; }
C++
public:
static property Color SystemControlColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlDarkBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlDarkBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemControlDarkBrush
C#
public static SolidColorBrush SystemControlDarkBrush { get; }
C++
public:
static property SolidColorBrush^ SystemControlDarkBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlDarkColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlDarkColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemControlDarkColor
C#
public static Color SystemControlDarkColor { get; }
C++
public:
static property Color SystemControlDarkColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlDarkDarkBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlDarkDarkBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemControlDarkDarkBrush
C#
public static SolidColorBrush SystemControlDarkDarkBrush { get; }
C++
public:
static property SolidColorBrush^ SystemControlDarkDarkBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlDarkDarkColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlDarkDarkColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemControlDarkDarkColor
C#
public static Color SystemControlDarkDarkColor { get; }
C++
public:
static property Color SystemControlDarkDarkColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlLightBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlLightBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemControlLightBrush
C#
public static SolidColorBrush SystemControlLightBrush { get; }
C++
public:
static property SolidColorBrush^ SystemControlLightBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlLightColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlLightColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemControlLightColor
C#
public static Color SystemControlLightColor { get; }
C++
public:
static property Color SystemControlLightColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlLightLightBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlLightLightBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemControlLightLightBrush
C#
public static SolidColorBrush SystemControlLightLightBrush { get; }
C++
public:
static property SolidColorBrush^ SystemControlLightLightBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlLightLightColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlLightLightColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemControlLightLightColor
C#
public static Color SystemControlLightLightColor { get; }
C++
public:
static property Color SystemControlLightLightColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlTextBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlTextBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemControlTextBrush
C#
public static SolidColorBrush SystemControlTextBrush { get; }
C++
public:
static property SolidColorBrush^ SystemControlTextBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemControlTextColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemControlTextColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemControlTextColor
C#
public static Color SystemControlTextColor { get; }
C++
public:
static property Color SystemControlTextColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemDesktopBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemDesktopBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemDesktopBrush
C#
public static SolidColorBrush SystemDesktopBrush { get; }
C++
public:
static property SolidColorBrush^ SystemDesktopBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemDesktopColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemDesktopColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemDesktopColor
C#
public static Color SystemDesktopColor { get; }
C++
public:
static property Color SystemDesktopColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemGradientActiveCaptionBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemGradientActiveCaptionBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemGradientActiveCaptionBrush
C#
public static SolidColorBrush SystemGradientActiveCaptionBrush { get; }
C++
public:
static property SolidColorBrush^ SystemGradientActiveCaptionBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemGradientActiveCaptionColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemGradientActiveCaptionColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemGradientActiveCaptionColor
C#
public static Color SystemGradientActiveCaptionColor { get; }
C++
public:
static property Color SystemGradientActiveCaptionColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemGradientInactiveCaptionBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemGradientInactiveCaptionBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemGradientInactiveCaptionBrush
C#
public static SolidColorBrush SystemGradientInactiveCaptionBrush { get; }
C++
public:
static property SolidColorBrush^ SystemGradientInactiveCaptionBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemGradientInactiveCaptionColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemGradientInactiveCaptionColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemGradientInactiveCaptionColor
C#
public static Color SystemGradientInactiveCaptionColor { get; }
C++
public:
static property Color SystemGradientInactiveCaptionColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemGrayTextBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemGrayTextBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemGrayTextBrush
C#
public static SolidColorBrush SystemGrayTextBrush { get; }
C++
public:
static property SolidColorBrush^ SystemGrayTextBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemGrayTextColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemGrayTextColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemGrayTextColor
C#
public static Color SystemGrayTextColor { get; }
C++
public:
static property Color SystemGrayTextColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemHighlightBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemHighlightBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemHighlightBrush
C#
public static SolidColorBrush SystemHighlightBrush { get; }
C++
public:
static property SolidColorBrush^ SystemHighlightBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemHighlightColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemHighlightColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemHighlightColor
C#
public static Color SystemHighlightColor { get; }
C++
public:
static property Color SystemHighlightColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemHighlightTextBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemHighlightTextBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemHighlightTextBrush
C#
public static SolidColorBrush SystemHighlightTextBrush { get; }
C++
public:
static property SolidColorBrush^ SystemHighlightTextBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemHighlightTextColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemHighlightTextColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemHighlightTextColor
C#
public static Color SystemHighlightTextColor { get; }
C++
public:
static property Color SystemHighlightTextColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemHotTrackBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemHotTrackBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemHotTrackBrush
C#
public static SolidColorBrush SystemHotTrackBrush { get; }
C++
public:
static property SolidColorBrush^ SystemHotTrackBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemHotTrackColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemHotTrackColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemHotTrackColor
C#
public static Color SystemHotTrackColor { get; }
C++
public:
static property Color SystemHotTrackColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemInactiveBorderBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemInactiveBorderBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemInactiveBorderBrush
C#
public static SolidColorBrush SystemInactiveBorderBrush { get; }
C++
public:
static property SolidColorBrush^ SystemInactiveBorderBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemInactiveBorderColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemInactiveBorderColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemInactiveBorderColor
C#
public static Color SystemInactiveBorderColor { get; }
C++
public:
static property Color SystemInactiveBorderColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemInactiveCaptionBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemInactiveCaptionBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemInactiveCaptionBrush
C#
public static SolidColorBrush SystemInactiveCaptionBrush { get; }
C++
public:
static property SolidColorBrush^ SystemInactiveCaptionBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemInactiveCaptionColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemInactiveCaptionColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemInactiveCaptionColor
C#
public static Color SystemInactiveCaptionColor { get; }
C++
public:
static property Color SystemInactiveCaptionColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemInactiveCaptionTextBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemInactiveCaptionTextBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemInactiveCaptionTextBrush
C#
public static SolidColorBrush SystemInactiveCaptionTextBrush { get; }
C++
public:
static property SolidColorBrush^ SystemInactiveCaptionTextBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemInactiveCaptionTextColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemInactiveCaptionTextColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemInactiveCaptionTextColor
C#
public static Color SystemInactiveCaptionTextColor { get; }
C++
public:
static property Color SystemInactiveCaptionTextColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemInfoBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemInfoBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemInfoBrush
C#
public static SolidColorBrush SystemInfoBrush { get; }
C++
public:
static property SolidColorBrush^ SystemInfoBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemInfoColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemInfoColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemInfoColor
C#
public static Color SystemInfoColor { get; }
C++
public:
static property Color SystemInfoColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemInfoTextBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemInfoTextBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemInfoTextBrush
C#
public static SolidColorBrush SystemInfoTextBrush { get; }
C++
public:
static property SolidColorBrush^ SystemInfoTextBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemInfoTextColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemInfoTextColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemInfoTextColor
C#
public static Color SystemInfoTextColor { get; }
C++
public:
static property Color SystemInfoTextColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemMenuBarBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemMenuBarBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemMenuBarBrush
C#
public static SolidColorBrush SystemMenuBarBrush { get; }
C++
public:
static property SolidColorBrush^ SystemMenuBarBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemMenuBarColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemMenuBarColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemMenuBarColor
C#
public static Color SystemMenuBarColor { get; }
C++
public:
static property Color SystemMenuBarColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemMenuBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemMenuBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemMenuBrush
C#
public static SolidColorBrush SystemMenuBrush { get; }
C++
public:
static property SolidColorBrush^ SystemMenuBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemMenuColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemMenuColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemMenuColor
C#
public static Color SystemMenuColor { get; }
C++
public:
static property Color SystemMenuColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemMenuHighlightBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemMenuHighlightBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemMenuHighlightBrush
C#
public static SolidColorBrush SystemMenuHighlightBrush { get; }
C++
public:
static property SolidColorBrush^ SystemMenuHighlightBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemMenuHighlightColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemMenuHighlightColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemMenuHighlightColor
C#
public static Color SystemMenuHighlightColor { get; }
C++
public:
static property Color SystemMenuHighlightColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemMenuTextBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemMenuTextBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemMenuTextBrush
C#
public static SolidColorBrush SystemMenuTextBrush { get; }
C++
public:
static property SolidColorBrush^ SystemMenuTextBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemMenuTextColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemMenuTextColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemMenuTextColor
C#
public static Color SystemMenuTextColor { get; }
C++
public:
static property Color SystemMenuTextColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemScrollBarBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemScrollBarBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemScrollBarBrush
C#
public static SolidColorBrush SystemScrollBarBrush { get; }
C++
public:
static property SolidColorBrush^ SystemScrollBarBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemScrollBarColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemScrollBarColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemScrollBarColor
C#
public static Color SystemScrollBarColor { get; }
C++
public:
static property Color SystemScrollBarColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemWindowBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemWindowBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemWindowBrush
C#
public static SolidColorBrush SystemWindowBrush { get; }
C++
public:
static property SolidColorBrush^ SystemWindowBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemWindowColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemWindowColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemWindowColor
C#
public static Color SystemWindowColor { get; }
C++
public:
static property Color SystemWindowColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemWindowFrameBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemWindowFrameBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemWindowFrameBrush
C#
public static SolidColorBrush SystemWindowFrameBrush { get; }
C++
public:
static property SolidColorBrush^ SystemWindowFrameBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemWindowFrameColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemWindowFrameColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemWindowFrameColor
C#
public static Color SystemWindowFrameColor { get; }
C++
public:
static property Color SystemWindowFrameColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemWindowTextBrush Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemWindowTextBrush As SolidColorBrush
Visual Basic (Usage)
Dim value As SolidColorBrush

value = SystemColorWorkaround.SystemWindowTextBrush
C#
public static SolidColorBrush SystemWindowTextBrush { get; }
C++
public:
static property SolidColorBrush^ SystemWindowTextBrush {
    SolidColorBrush^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


SystemColorWorkaround.SystemWindowTextColor Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SystemWindowTextColor As Color
Visual Basic (Usage)
Dim value As Color

value = SystemColorWorkaround.SystemWindowTextColor
C#
public static Color SystemWindowTextColor { get; }
C++
public:
static property Color SystemWindowTextColor {
    Color get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

SystemColorWorkaround Class
SystemColorWorkaround Members


ToolBarDescription Class
See Also Members
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Class ToolBarDescription
    Implements IToolBarDescription
Visual Basic (Usage)
Dim instance As ToolBarDescription
C#
public class ToolBarDescription : IToolBarDescription
C++
public ref class ToolBarDescription : IToolBarDescription

Inheritance Hierarchy

System.Object
Microsoft.Expression.Web.ToolBarDescription

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ToolBarDescription Members


ToolBarDescription Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the ToolBarDescription type.

Public Constructors

Name | Description
ToolBarDescription |
Top

Public Properties

Name | Description
Name |
Visible |
Top

Public Methods (see also Protected Methods)

Name | Description
Equals | Overloaded. (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ReferenceEquals | (Inherited from Object)
ToString | (Inherited from Object)
Top

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)
Top

See Also

Reference

ToolBarDescription Class


ToolBarDescription Constructor
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    visible As Boolean _
)
Visual Basic (Usage)
Dim name As String
Dim visible As Boolean

Dim instance As New ToolBarDescription(name, visible)
C#
public ToolBarDescription (
    string name,
    bool visible
)
C++
public:
ToolBarDescription (
    String^ name,
    bool visible
)

See Also

Reference

ToolBarDescription Class
ToolBarDescription Members


ToolBarDescription Methods
See Also
[image]

Public Methods (see also Protected Methods)

Name | Description
Equals | Overloaded. (Inherited from Object)
GetHashCode | (Inherited from Object)
GetType | (Inherited from Object)
ReferenceEquals | (Inherited from Object)
ToString | (Inherited from Object)

Protected Methods

Name | Description
Finalize | (Inherited from Object)
MemberwiseClone | (Inherited from Object)

See Also

Reference

ToolBarDescription Class


ToolBarDescription Properties
See Also
[image]

Public Properties

Name | Description
Name |
Visible |

See Also

Reference

ToolBarDescription Class


ToolBarDescription.Name Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage)
Dim instance As ToolBarDescription
Dim value As String

value = instance.Name

instance.Name = value
C#
public string Name { get; set; }
C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ToolBarDescription Class
ToolBarDescription Members


ToolBarDescription.Visible Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage)
Dim instance As ToolBarDescription
Dim value As Boolean

value = instance.Visible

instance.Visible = value
C#
public bool Visible { get; set; }
C++
public:
virtual property bool Visible {
    bool get () sealed;
    void set (bool value) sealed;
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

ToolBarDescription Class
ToolBarDescription Members


XWebApplication Class
See Also Members
[image]

Implements the main application class.

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Design", "CA1001:TypesThatOwnDisposableFieldsShouldBeDisposable")> _
Public NotInheritable Class XWebApplication
    Inherits ExpressionApplication
Visual Basic (Usage)
Dim instance As XWebApplication
C#
[SuppressMessageAttribute("Microsoft.Design", "CA1001:TypesThatOwnDisposableFieldsShouldBeDisposable")]
public sealed class XWebApplication : ExpressionApplication
C++
[SuppressMessageAttribute(L"Microsoft.Design", L"CA1001:TypesThatOwnDisposableFieldsShouldBeDisposable")]
public ref class XWebApplication sealed : public ExpressionApplication

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.Application
Microsoft.Expression.Framework.ExpressionApplication
Microsoft.Expression.Web.XWebApplication

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

XWebApplication Members


XWebApplication Members
See Also Constructors Events Methods Properties Explicit Interface Implementations
[image]

The following tables list the members exposed by the XWebApplication type.

Public Constructors

Name | Description
XWebApplication | Initializes the application.
Top

Public Properties (see also Protected Properties)

Name | Description
CommonFontsLocation | (Inherited from ExpressionApplication)
Current | (Inherited from Application)
CustomerFeedbackApplicationIdentifier | Overridden.
Dispatcher | (Inherited from DispatcherObject)
ExpressionInformationService | (Inherited from ExpressionApplication)
InitialSplashScreen | (Inherited from ExpressionApplication)
IsReleaseVersion | (Inherited from ExpressionApplication)
LongApplicationName | Overridden.
MainWindow | (Inherited from Application)
PoliciesRegistryPath | (Inherited from ExpressionApplication)
Properties | (Inherited from Application)
RegistryPath | (Inherited from ExpressionApplication)
RegistryRoot |
ResourceAssembly | (Inherited from Application)
Resources | (Inherited from Application)
Services | (Inherited from ExpressionApplication)
ShortApplicationName | Overridden.
ShutdownMode | (Inherited from Application)
StartupUri | (Inherited from Application)
StudioKeyRegistryPath | (Inherited from ExpressionApplication)
Version | (Inherited from ExpressionApplication)
VersionedPoliciesRegistryPath | (Inherited from ExpressionApplication)
VersionedRegistryPath | (Inherited from ExpressionApplication)
WelcomeSplashScreen | (Inherited from ExpressionApplication)
Windows | (Inherited from Application)
Top

Protected Properties

Name | Description
ProgramName | (Inherited from ExpressionApplication)
Top

Public Methods (see also Protected Methods)

Name | Description
CheckAccess | (Inherited from DispatcherObject)
Dispose | Overloaded. (Inherited from ExpressionApplication)
DoEvents | (Inherited from ExpressionApplication)
Equals | Overloaded. (Inherited from Object)
FindResource | (Inherited from Application)
GetContentStream | (Inherited from Application)
GetCookie | (Inherited from Application)
GetHashCode | (Inherited from Object)
GetRemoteStream | (Inherited from Application)
GetResourceStream | (Inherited from Application)
GetType | (Inherited from Object)
LoadComponent | Overloaded. (Inherited from Application)
ReferenceEquals | (Inherited from Object)
Run | Overloaded. (Inherited from Application)
SetCookie | (Inherited from Application)
Shutdown | Overloaded. (Inherited from Application)
ToString | (Inherited from Object)
TryFindResource | (Inherited from Application)
VerifyAccess | (Inherited from DispatcherObject)
Top

Protected Methods

Name | Description
CloseSplashScreens | (Inherited from ExpressionApplication)
CloseWelcomeSplashScreen | (Inherited from ExpressionApplication)
CreateFeedbackService | (Inherited from ExpressionApplication)
CreateInitialServices | (Inherited from ExpressionApplication)
Dispose | Overloaded. (Inherited from ExpressionApplication)
EndGlobalPerformanceInstrumentation | (Inherited from ExpressionApplication)
Finalize | (Inherited from Object)
FocusScopeManagerReturnFocusCallback | (Inherited from ExpressionApplication)
InitializeLicenseService | (Inherited from ExpressionApplication)
InitializeUnhandledExceptionHandlers | (Inherited from ExpressionApplication)
MemberwiseClone | (Inherited from Object)
OnActivated | (Inherited from Application)
OnDeactivated | (Inherited from Application)
OnExit | Destroys the application services ApplicationServices and raises the Exit event. (Inherited from ExpressionApplication)
OnFragmentNavigation | (Inherited from Application)
OnLoadCompleted | (Inherited from Application)
OnNavigated | (Inherited from Application)
OnNavigating | (Inherited from Application)
OnNavigationFailed | (Inherited from Application)
OnNavigationProgress | (Inherited from Application)
OnNavigationStopped | (Inherited from Application)
OnSessionEnding | (Inherited from Application)
OnStartup | Initializes the run of the application and raises the Startup event. (Inherited from ExpressionApplication)
PerformFinalActionsBeforeWatsonDump | (Inherited from ExpressionApplication)
PrepareToTerminateOnUnrecoverableException | (Inherited from ExpressionApplication)
ProcessGeneralCommandLineCommands | (Inherited from ExpressionApplication)
ReplaceWithWelcomeSplashScreen | (Inherited from ExpressionApplication)
RunApplication | (Inherited from ExpressionApplication)
ShouldEatException | (Inherited from ExpressionApplication)
ShouldTerminateOnException | (Inherited from ExpressionApplication)
ShowSafeMessageBox | (Inherited from ExpressionApplication)
StartGlobalPerformanceInstrumentation | (Inherited from ExpressionApplication)
UnhandledExceptionPerApplicationHandler | (Inherited from ExpressionApplication)
Top

Public Events

Name | Description
Activated | (Inherited from Application)
Deactivated | (Inherited from Application)
DispatcherUnhandledException | (Inherited from Application)
Exit | (Inherited from Application)
FragmentNavigation | (Inherited from Application)
LoadCompleted | (Inherited from Application)
Navigated | (Inherited from Application)
Navigating | (Inherited from Application)
NavigationFailed | (Inherited from Application)
NavigationProgress | (Inherited from Application)
NavigationStopped | (Inherited from Application)
SessionEnding | (Inherited from Application)
Startup | (Inherited from Application)
Top

Explicit Interface Implementations

Name | Description
System.Windows.Markup.IQueryAmbient.IsAmbientPropertyAvailable | (Inherited from Application)
Top

See Also

Reference

XWebApplication Class


XWebApplication Constructor
See Also
[image]

Initializes the application.

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Usage", "CA1806")> _
Public Sub New ( _
    splashScreen As SplashScreen _
)
Visual Basic (Usage)
Dim splashScreen As SplashScreen

Dim instance As New XWebApplication(splashScreen)
C#
[SuppressMessageAttribute("Microsoft.Usage", "CA1806")]
public XWebApplication (
    SplashScreen splashScreen
)
C++
[SuppressMessageAttribute(L"Microsoft.Usage", L"CA1806")]
public:
XWebApplication (
    SplashScreen^ splashScreen
)

Parameters

splashScreen

See Also

Reference

XWebApplication Class
XWebApplication Members


XWebApplication Methods
See Also
[image]

Public Methods (see also Protected Methods)

Name | Description
CheckAccess | (Inherited from DispatcherObject)
Dispose | Overloaded. (Inherited from ExpressionApplication)
DoEvents | (Inherited from ExpressionApplication)
Equals | Overloaded. (Inherited from Object)
FindResource | (Inherited from Application)
GetContentStream | (Inherited from Application)
GetCookie | (Inherited from Application)
GetHashCode | (Inherited from Object)
GetRemoteStream | (Inherited from Application)
GetResourceStream | (Inherited from Application)
GetType | (Inherited from Object)
LoadComponent | Overloaded. (Inherited from Application)
ReferenceEquals | (Inherited from Object)
Run | Overloaded. (Inherited from Application)
SetCookie | (Inherited from Application)
Shutdown | Overloaded. (Inherited from Application)
ToString | (Inherited from Object)
TryFindResource | (Inherited from Application)
VerifyAccess | (Inherited from DispatcherObject)

Protected Methods

Name | Description
CloseSplashScreens | (Inherited from ExpressionApplication)
CloseWelcomeSplashScreen | (Inherited from ExpressionApplication)
CreateFeedbackService | (Inherited from ExpressionApplication)
CreateInitialServices | (Inherited from ExpressionApplication)
Dispose | Overloaded. (Inherited from ExpressionApplication)
EndGlobalPerformanceInstrumentation | (Inherited from ExpressionApplication)
Finalize | (Inherited from Object)
FocusScopeManagerReturnFocusCallback | (Inherited from ExpressionApplication)
InitializeLicenseService | (Inherited from ExpressionApplication)
InitializeUnhandledExceptionHandlers | (Inherited from ExpressionApplication)
MemberwiseClone | (Inherited from Object)
OnActivated | (Inherited from Application)
OnDeactivated | (Inherited from Application)
OnExit | Destroys the application services ApplicationServices and raises the Exit event. (Inherited from ExpressionApplication)
OnFragmentNavigation | (Inherited from Application)
OnLoadCompleted | (Inherited from Application)
OnNavigated | (Inherited from Application)
OnNavigating | (Inherited from Application)
OnNavigationFailed | (Inherited from Application)
OnNavigationProgress | (Inherited from Application)
OnNavigationStopped | (Inherited from Application)
OnSessionEnding | (Inherited from Application)
OnStartup | Initializes the run of the application and raises the Startup event. (Inherited from ExpressionApplication)
PerformFinalActionsBeforeWatsonDump | (Inherited from ExpressionApplication)
PrepareToTerminateOnUnrecoverableException | (Inherited from ExpressionApplication)
ProcessGeneralCommandLineCommands | (Inherited from ExpressionApplication)
ReplaceWithWelcomeSplashScreen | (Inherited from ExpressionApplication)
RunApplication | (Inherited from ExpressionApplication)
ShouldEatException | (Inherited from ExpressionApplication)
ShouldTerminateOnException | (Inherited from ExpressionApplication)
ShowSafeMessageBox | (Inherited from ExpressionApplication)
StartGlobalPerformanceInstrumentation | (Inherited from ExpressionApplication)
UnhandledExceptionPerApplicationHandler | (Inherited from ExpressionApplication)

Explicit Interface Implementations

Name | Description
System.Windows.Markup.IQueryAmbient.IsAmbientPropertyAvailable | (Inherited from Application)

See Also

Reference

XWebApplication Class


XWebApplication Properties
See Also
[image]

Public Properties (see also Protected Properties)

Name | Description
CommonFontsLocation | (Inherited from ExpressionApplication)
Current | (Inherited from Application)
CustomerFeedbackApplicationIdentifier | Overridden.
Dispatcher | (Inherited from DispatcherObject)
ExpressionInformationService | (Inherited from ExpressionApplication)
InitialSplashScreen | (Inherited from ExpressionApplication)
IsReleaseVersion | (Inherited from ExpressionApplication)
LongApplicationName | Overridden.
MainWindow | (Inherited from Application)
PoliciesRegistryPath | (Inherited from ExpressionApplication)
Properties | (Inherited from Application)
RegistryPath | (Inherited from ExpressionApplication)
RegistryRoot |
ResourceAssembly | (Inherited from Application)
Resources | (Inherited from Application)
Services | (Inherited from ExpressionApplication)
ShortApplicationName | Overridden.
ShutdownMode | (Inherited from Application)
StartupUri | (Inherited from Application)
StudioKeyRegistryPath | (Inherited from ExpressionApplication)
Version | (Inherited from ExpressionApplication)
VersionedPoliciesRegistryPath | (Inherited from ExpressionApplication)
VersionedRegistryPath | (Inherited from ExpressionApplication)
WelcomeSplashScreen | (Inherited from ExpressionApplication)
Windows | (Inherited from Application)

Protected Properties

Name | Description
ProgramName | (Inherited from ExpressionApplication)

See Also

Reference

XWebApplication Class


XWebApplication.CustomerFeedbackApplicationIdentifier Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CustomerFeedbackApplicationIdentifier As Integer
Visual Basic (Usage)
Dim instance As XWebApplication
Dim value As Integer

value = instance.CustomerFeedbackApplicationIdentifier
C#
public override int CustomerFeedbackApplicationIdentifier { get; }
C++
public:
virtual property int CustomerFeedbackApplicationIdentifier {
    int get () override;
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

XWebApplication Class
XWebApplication Members


XWebApplication.LongApplicationName Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property LongApplicationName As String
Visual Basic (Usage)
Dim instance As XWebApplication
Dim value As String

value = instance.LongApplicationName
C#
public override string LongApplicationName { get; }
C++
public:
virtual property String^ LongApplicationName {
    String^ get () override;
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

XWebApplication Class
XWebApplication Members


XWebApplication.RegistryRoot Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property RegistryRoot As String
Visual Basic (Usage)
Dim value As String

value = XWebApplication.RegistryRoot
C#
public static string RegistryRoot { get; }
C++
public:
static property String^ RegistryRoot {
    String^ get ();
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

XWebApplication Class
XWebApplication Members


XWebApplication.ShortApplicationName Property
See Also
[image]

Namespace: Microsoft.Expression.Web
Assembly: Microsoft.Expression.Web (in microsoft.expression.web.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ShortApplicationName As String
Visual Basic (Usage)
Dim instance As XWebApplication
Dim value As String

value = instance.ShortApplicationName
C#
public override string ShortApplicationName { get; }
C++
public:
virtual property String^ ShortApplicationName {
    String^ get () override;
}

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

See Also

Reference

XWebApplication Class
XWebApplication Members


XWebApplication Events
See Also
[image]

Public Events

Name | Description
Activated | (Inherited from Application)
Deactivated | (Inherited from Application)
DispatcherUnhandledException | (Inherited from Application)
Exit | (Inherited from Application)
FragmentNavigation | (Inherited from Application)
LoadCompleted | (Inherited from Application)
Navigated | (Inherited from Application)
Navigating | (Inherited from Application)
NavigationFailed | (Inherited from Application)
NavigationProgress | (Inherited from Application)
NavigationStopped | (Inherited from Application)
SessionEnding | (Inherited from Application)
Startup | (Inherited from Application)

See Also

Reference

XWebApplication Class